Bug 23997 - Perl warnings on new glibc 2.2-12
Summary: Perl warnings on new glibc 2.2-12
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-14 17:30 UTC by James Brents
Modified: 2016-11-24 14:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-14 18:06:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Brents 2001-01-14 17:30:56 UTC
I have recently upgraded glibc to 2.2-12 as in the RedHat errata. Since
then, I now have these warnings on invoking perl:
[syonic@Mars syonic]$ perl
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


Perl worked fine before this, And I only upgraded glibc at the time, so im
sure it has to be related.. It exists on all machines, as all have upgraded
to the new glibc.

Comment 1 Jakub Jelinek 2001-01-14 18:06:20 UTC
Cannot reproduce this. The only thing which comes to my mind which
would cause this is that you don't have glibc-common installed.
How have you done the upgrade? If using rpm -F --nodeps, then it
would explain it. The errata described you should do:
rpm -Uvh glibc-2* glibc-common-2*
rpm -Fvh glibc-[dp]* nscd*

Comment 2 James Brents 2001-01-14 18:37:24 UTC
Thanks for the advice, my problem was that glibc-common was added, and my perl
script that I made to automate updates never looked for that. After installing
glibc-common the problem is resolved. This is not a bug, but user error. Marking
bug as such.


Note You need to log in before you can comment on or make changes to this bug.