Bug 239977 - Not able to enter a "/" or "-" within anaconda in virtual machine
Summary: Not able to enter a "/" or "-" within anaconda in virtual machine
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2007-05-13 20:41 UTC by Robert Scheck
Modified: 2018-04-11 17:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 02:38:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2007-05-13 20:41:58 UTC
Description of problem:
After entering

  virt-install --name kvm --file /home/robert/kvm.img --file-size 0.7 \
    --bridge eth0 --vnc --connect qemu:///system --paravirt \
    --location /home/robert/boot.iso --ram=256

a vncviewer opens up. When the boot.iso is the network boot image of Fedora 7, 
I should be able to enter URLs in the upcoming ananconda within the vncviewer. 
Unfortunately, after choosing "us" keyboard, I can't enter a "-" sign and when 
choosing "de", I'm not able to enter a "/" within anaconda. This is somehow 
broken...

Version-Release number of selected component (if applicable):
python-virtinst-0.103.0-3

How reproducible:
Everytime.

Expected results:
Working stuff...

Comment 1 Robert Scheck 2007-05-13 20:52:20 UTC
Oh, wrong way: With "us" charset I can't enter an "/" and with "de" I'm not 
able to enter a "-" character within anaconda.

Comment 2 Daniel Berrange 2007-05-14 13:46:46 UTC
Can you run same virt-install command, adding in the --debug flag & attach the
output to this bug. The /var/log/xen/xend.log will be useful too.  

Finally, what keyboard layout is your local X desktop session using & what is in
/etc/sysconfig/keyboard ?


Comment 3 Robert Scheck 2007-05-15 20:28:39 UTC
I'm using not Xen (KVM/KQEMU) and the local X desktop has the same 
configuration as follows (but the problem also appears via remote VNC from a 
windows machine):

[root@linuxtag pub]# cat /etc/sysconfig/keyboard
KEYBOARDTYPE="pc"
KEYTABLE="de-latin1-nodeadkeys"
[root@linuxtag pub]#

Comment 4 Daniel Berrange 2007-05-16 18:45:24 UTC
> Can you run same virt-install command, adding in the --debug flag & attach the
> output to this bug. 

Still need that info.


Comment 5 Robert Scheck 2007-05-17 17:46:26 UTC
Output is simply the same as at bug #240127 initial description (which is also 
by me).

Comment 6 Daniel Berrange 2007-05-17 17:55:57 UTC
Ok, please re-try the virt-install command adding in

  --keymap de

The VNC  server doesn't support "de-latin1-nodeadkeys", but hopefully a generic
 'de' keyboard would get a more functional setup.

You can see a list of supported keymaps with 'rpm -ql xen | grep keymaps'

NB, local X desktop, the VNC server, and the guest X server must all be
configured to use the same keymap if possible. So setting them all to 'de' (or a
close variation) would be ideal


Comment 7 Robert Scheck 2007-05-19 16:37:43 UTC
Well, I can set the keymap to 'de', 'us' etc. and in NO CASE 'de' or 'us' 
keyboard will work during setup. I'm not able to enter slashes anyway.

Comment 8 Markus Armbruster 2007-05-24 20:34:46 UTC
This is actually a bug in libvirt: keymap support is missing for KVM. 
Reassigning...


Comment 9 Robert Scheck 2007-05-24 20:35:49 UTC
...and broken for Xen!

Comment 10 Alexander Boström 2007-06-10 16:07:07 UTC
Probable workaround: I'm using se-latin1, and I can enter a / using the numeric
keypad.

Comment 11 Matěj Cepl 2007-09-18 13:37:30 UTC
I have in host computer default locale cs_CZ.UTF-8 and after entering any
non-letter characters in kvm machine through virt-viewer or through vncviewer
(including but by far not limited to "/") via numerical keyboard (because
sometimes double-translated keyboard doesn't give me numerical characters and
what's on the US keyboard above numbers), keyboard gets stuck with Shift on all
keys. Sometimes it helped switching between locked and non-locked mouse in
virt-viewer (by pressing Ctrl+Alt), sometimes loging out and loging in to Gnome
session in the guest machine, but sometimes I have to shutdown whole KVM guest
and restart it.

Comment 12 Robert Scheck 2007-12-16 13:13:38 UTC
Ping?

Comment 13 Jesse Keating 2008-03-31 17:52:04 UTC
Is this still an issue?  I've been doing installs in virt-manager for a bit and
haven't had a problem putting in a /


Note You need to log in before you can comment on or make changes to this bug.