Bug 240001 - evolution prints in A4, I can't change settings
Summary: evolution prints in A4, I can't change settings
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-14 10:06 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 04:18:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 446894 None None None Never

Description Jonathan Kamens 2007-05-14 10:06:04 UTC
Evolution prints in A4 even though my locale is "en_US" (confirmed with
"locale") and "papersize" returns "letter".

The drop-downs on the print dialog for setting the paper size are greyed out and
say "Not Available".

I have evolution-2.10.1-4.fc7 and all other versions from Rawhide current as of
last night when I updated my system (if you need to know the version of some
other package, let me know).

As you might imagine, this is rather annoying, since I don't have A4 paper and
hence can't print from evolution right now.

Comment 1 Thomas J. Baker 2007-05-21 19:44:45 UTC
I have the same problem. Upstream bug is
http://bugzilla.gnome.org/show_bug.cgi?id=425973 which admits to the bug bug
also says it won't be fixed until 2.12! That bug is also marked a dup of
http://bugzilla.gnome.org/show_bug.cgi?id=426816 which is more of a catch all.
Is this going to be fixed before F7?

Comment 2 Matthew Barnes 2007-05-21 20:22:53 UTC
The hardcoded paper-size issue mentioned in the first upstream bug was fixed for
Evolution 2.10 but rendering issues remain from the GtkPrint migration that
occurred during the 2.9 series.  I'm working on fixing the remaining issues, but
F7 is already frozen.

Comment 3 Jonathan Kamens 2007-05-21 20:28:18 UTC
So you're saying that you're going to ship F7 without the ability to print to 
standard paper sizes in Fedora's preferred email client?

Frankly, this strikes me as a severe enough issue that it should be a show-
stopper; you shouldn't be able to ship a release with a bug like this in it.

At the very least, I hope it will be fixed in an F7 update shortly after 
release.


Comment 4 Thomas J. Baker 2007-05-21 20:31:40 UTC
I'll look for an update or maybe skim koji. The update will probably be out
before I've gotton F7 mirrored. Thanks.


Comment 5 Matthew Barnes 2007-05-21 20:34:44 UTC
It has to fixed upstream first.  This isn't a Fedora-specific bug.

Comment 6 Matthew Barnes 2007-06-13 10:03:01 UTC
I've opened an upstream bug [1] with patches to try and deal with these and
other printing issues in Evolution's mailer.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=446894

Comment 7 Matthew Barnes 2007-08-01 04:18:15 UTC
Fixed upstream in evolution-2.11.5 / gtkhtml3-3.15.5.

Comment 8 Craig White 2007-08-01 16:03:17 UTC
Please incorporate upstream fix into Fedora 7 - It's a problem

Comment 9 Matthew Barnes 2007-08-01 16:15:25 UTC
I can't because it requires an API change to GtkHtml.

It will be fixed in Fedora 8.


Note You need to log in before you can comment on or make changes to this bug.