Bug 240011 - yum install prints errors for fuse sshfs filesystems
Summary: yum install prints errors for fuse sshfs filesystems
Status: CLOSED DUPLICATE of bug 220991
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-14 11:42 UTC by Eric Harney
Modified: 2014-01-21 22:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 19:22:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum install output (3.20 KB, text/plain)
2007-05-14 11:42 UTC, Eric Harney
no flags Details

Description Eric Harney 2007-05-14 11:42:02 UTC
Description of problem:
If a "yum install" is done, errors print for mounted fuse sshfs filesystems
saying "Permission denied" during the transaction test and transaction.

Version-Release number of selected component (if applicable):
yum-3.1.7-2.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Mount a filesystem with sshfs as a non-root user.  "sshfs host:/ directory"
2. yum install <something>
  
Actual results:
Unnecessary error messages are printed during the install

Comment 1 Eric Harney 2007-05-14 11:42:02 UTC
Created attachment 154642 [details]
yum install output

Comment 2 Jeremy Katz 2007-05-14 18:46:11 UTC
What output do you get from 'stat /home/emh/test/fusemount'?  And are there any
avcs from selinux?

Comment 3 Eric Harney 2007-05-14 19:03:20 UTC
The root user can't stat or otherwise access /home/emh/test/fusemount.. it gets
the same permission denied error.   I think this is normal behavior as fuse is
setup per-user.  It may be the case that something doesn't handle this case
correctly, as the fs is listed in /etc/mtab, but only accessible to my user account.

I haven't seen any events logged from selinux.  Further poking has also revealed
that this message is output from any "rpm -i" or "rpm -e" command, and is not
yum-specific.

Comment 4 Jeremy Katz 2007-05-14 19:22:37 UTC
The error is entirely appropriate, then.  rpm has to do a stat of all mounted
filesystems when trying to determine if there's enough available space.  Giving
feedback that one of the filesystems couldnt' be stated is entirely reasonable.

Comment 5 Eric Harney 2007-05-14 19:35:20 UTC

*** This bug has been marked as a duplicate of 220991 ***


Note You need to log in before you can comment on or make changes to this bug.