Bug 240016 - invalid reference count for sata controllers
Summary: invalid reference count for sata controllers
Status: CLOSED DUPLICATE of bug 241215
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.5
Hardware: i386 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 246028
TreeView+ depends on / blocked
 
Reported: 2007-05-14 12:51 UTC by Sandeep K. Shandilya
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-24 14:20:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lsmod on a Poweredge 830. (1.07 KB, text/plain)
2007-05-14 12:51 UTC, Sandeep K. Shandilya
no flags Details

Description Sandeep K. Shandilya 2007-05-14 12:51:53 UTC
Description of problem:
The reference count of the ata_piix or sata_svw module is incorrect for an
attachment of lsmod.txt.

Version-Release number of selected component (if applicable):
kernel version in 2.6.9-55 4.5.

How reproducible:
always.

Steps to Reproduce:
1. Install linux on a PowerEdge 830 on a scsi/SAS configuration.
2. Add a disk to the ata_piix sata port.
3. modprobe the ata_piix module.
  
Actual results:
The ref count of the ata_piix module is a very high number.

Expected results:
the ref count of the ata_piix module should be zero because there are no files
open on the controller.

Additional info:
I first observed this while trying to root cause bugzilla #238855.
If I make the disk busy by creating a partition and formatting the part and
mount the disk. the reference count becomes zero and I can now remove the module
even if the partition is mounted.

Comment 1 Sandeep K. Shandilya 2007-05-14 12:51:53 UTC
Created attachment 154643 [details]
output of lsmod on a Poweredge 830.

Comment 2 Bryn M. Reeves 2007-05-24 14:20:23 UTC

*** This bug has been marked as a duplicate of 241215 ***


Note You need to log in before you can comment on or make changes to this bug.