This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 240018 - yum-priorities plugin makes yum unusable
yum-priorities plugin makes yum unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 09:32 EDT by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.2.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 18:12:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2007-05-14 09:32:02 EDT
After installing yum-priorities plugin yum takes forever to resolve
dependencies. With the plugin disables `yum list updates' takes about 7 seconds
on my Lenovo T60 with Centrino Duo & 2 gigs of RAM. With the plugin enabled
resolving dependencies took almost 1 hour (!). top showed that yum eats the CPU
all of the time. 
And that was only 51 packages to update.
Comment 1 Christian Lupien 2007-09-03 19:00:38 EDT
I found the same problem (it exists also with yum-protectbase).

I did some profiling and I found the problem is with yum itself. It is in the
_getSacks function of __init__.py in /usr/lib/python2.5/site-packages/yum
This gets called for each package that needs to be erased and when there are a
lot (like when using the dries repo at a lower priority than core/update which
means more than a 1000 deletes) it is a large slowdown.

The function checks for the existence of self._pkgSack but I guess the checks is
done by calling the __len__ which extracts the list of packages. I fixed the
problem by replacing 
  if self._pkgSack and thisrepo is None:
with 
  if self._pkgSack != None  and thisrepo is None:
at the top of the  _getSacks function.

With this change, using yum-priorities with the dries repo is not slow anymore.
Comment 2 Seth Vidal 2007-09-03 19:20:08 EDT
What ver of yum are you using right now?


Comment 3 Christian Lupien 2007-09-03 20:56:19 EDT
I am using yum 3.2.2. 
rpm -q yum is 
 yum-3.2.2-1.fc7
Comment 4 Seth Vidal 2007-09-03 21:17:57 EDT
Please try out yum 3.2.4 from updates-testing - I think you'll find it's no
longer slow.

Comment 5 Christian Lupien 2007-09-03 21:57:41 EDT
Yes, that fixed it.
Comment 6 Fedora Update System 2007-09-04 18:12:09 EDT
yum-3.2.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.