Bug 240051 - Enable kerberos4 support in cyrus sasl [patch]
Enable kerberos4 support in cyrus sasl [patch]
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 13:33 EDT by Derek Atkins
Modified: 2008-07-26 02:01 EDT (History)
0 users

See Also:
Fixed In Version: 2.1.22-15.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-26 02:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPECfile patch (1.80 KB, patch)
2007-05-14 13:33 EDT, Derek Atkins
no flags Details | Diff
Kerberos 4 patch to get the plugin to build (358 bytes, patch)
2007-05-14 13:35 EDT, Derek Atkins
no flags Details | Diff

  None (edit)
Description Derek Atkins 2007-05-14 13:33:12 EDT
Description of problem:

The IMAP servers at MIT only support krb4, not krb5/GSSAPI.  This means I need
krb4 cyrus support in order to contact them using Kerberos.  It would be nice if
cyrus-sasl have krb4 support enabled by default.  I've got two patches, one to
the SPEC file to enable krb4 support and one to the kerberos4 plugin to fix a
build error.

Version-Release number of selected component (if applicable):

cyrus-sasl-2.1.22-6

How reproducible:

100%

Steps to Reproduce:
1. yum search cyrus-sasl | grep -i krb4
2. yum search cyrus-sasl | grep -i kerberos
3.
  
Actual results:

No krb4 packages

Expected results:

I'd like a cyrus-sasl-krb4 package

Additional info:

See attachments for the patches.
Comment 1 Derek Atkins 2007-05-14 13:33:12 EDT
Created attachment 154675 [details]
SPECfile patch
Comment 2 Derek Atkins 2007-05-14 13:35:01 EDT
Created attachment 154676 [details]
Kerberos 4 patch to get the plugin to build

This patch just makes sure we use the Krb4 des headers and not the openssl des
headers which are different and apparently breaks the build.
Comment 4 Derek Atkins 2008-04-08 20:54:08 EDT
FYI, this is still an issue in 2.1.22-8
The patches in the previous attachment are still necessary but they apply cleanly.
Comment 5 Bug Zapper 2008-05-13 22:54:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Tomas Mraz 2008-07-02 02:09:33 EDT
Applied with minor changes in Fedora rawhide cyrus-sasl-2.1.22-15.fc10
Comment 7 Derek Atkins 2008-07-02 02:16:09 EDT
Cool!  Thanks.

Any chance of this getting back-ported to Fedora 9?
Comment 8 Fedora Update System 2008-07-02 03:51:52 EDT
cyrus-sasl-2.1.22-15.fc9 has been submitted as an update for Fedora 9
Comment 9 Fedora Update System 2008-07-02 23:16:30 EDT
cyrus-sasl-2.1.22-15.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyrus-sasl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6046
Comment 10 Fedora Update System 2008-07-26 02:01:31 EDT
cyrus-sasl-2.1.22-15.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.