Bug 240063 - suspend to ram is not choosable/not working. s1 is used instead
suspend to ram is not choosable/not working. s1 is used instead
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 15:44 EDT by Jan Falkenhagen
Modified: 2015-03-04 20:18 EST (History)
2 users (show)

See Also:
Fixed In Version: Fedora 7 Final
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-31 21:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Falkenhagen 2007-05-14 15:44:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.3) Gecko/20070417 Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3

Description of problem:
energy manager lonly lets me choose standby mode, not suspend to ram. Laptop model is an Acer Travelmate 800. STR/S3 worked flawlessly in fc5/fc6.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3142.fc7

How reproducible:
Always


Steps to Reproduce:
1. clicking through the config options of gnome energy manager
2.
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Nigel Cunningham 2007-05-14 19:07:49 EDT
Could you please show the results of "cat /sys/power/state"?
Comment 2 Jan Falkenhagen 2007-05-16 09:22:46 EDT
[jan@val ~]$ cat /sys/power/state
mem disk
Comment 3 Nigel Cunningham 2007-05-16 23:27:36 EDT
It looks like the energy manager has its story wrong. 'Mem' is suspend to ram,
and you would see standby there if S1 was supported.
Comment 4 Nigel Cunningham 2007-05-18 18:39:22 EDT
Does the menu say standby instead of suspend? If so, we should perhaps reassign
this to some other component. The next problem will of course be figuring out
which one.
Comment 5 Jan Falkenhagen 2007-05-19 02:59:53 EDT
No, it wasn't the menu saying standby. The LEDs of the laptop were blinking in a
manner that signaled S1 and not S3. Seems like the problem has disappeared with
kernel 2.6.21-1.3163.fc7. 

Unfortunately suspend not working any longer on my laptop at all. the leds seem
to blink (or not blink) the right way, but there is simply no activity any
longer when resuming. (hdd led is on, but there ist no hearable activity - one
time when resuming the caps-lock led was flashing in a constant intervalls.)
Comment 6 Jan Falkenhagen 2007-05-31 16:28:34 EDT
seems to be fiuxed in fc7 final.

Note You need to log in before you can comment on or make changes to this bug.