Bug 240073 - cron should use inotify instead of constantly stat'ing files.
cron should use inotify instead of constantly stat'ing files.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Brock Organ
:
Depends On:
Blocks: wakeup
  Show dependency treegraph
 
Reported: 2007-05-14 16:57 EDT by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 07:56:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2007-05-14 16:57:29 EDT
strace crond, and you'll see it wakes up once a minute to stat /etc/crontab,
/etc/cron.d and /var/spool/cron to look if anything changed.
This prevents the disk from ever spinning down when the system is otherwise idle.

If crond used inotify to find out that these files/dirs changed, it wouldn't
have to keep waking up at all.
Comment 1 Marcela Mašláňová 2007-07-24 03:51:01 EDT
Thanks for comment, I'm working on it in upstream and I'm planning after some
testing push it to rawhide.
Comment 2 Nick Lamb 2008-01-27 15:01:59 EST
How's this work coming? This is a very small contributor to unnecessary wakeups,
and with relatime it no longer keeps disks spun up either, but every little
helps, especially in core features like the cron daemon that can't really be
disabled.
Comment 3 Marcela Mašláňová 2008-01-31 06:47:22 EST
I agree with you that's important feature.
I rewrote the essential part of code, but there are still some features, options
which don't work yet. 
I'm not sure if I make it to F-9 release, because I definitely don't want push
untested package.
Comment 4 Bug Zapper 2008-05-13 22:54:17 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.