Bug 240087 - Anaconda presents wrong keyboard list for Bulgarian installations and crashes with ru_win
Anaconda presents wrong keyboard list for Bulgarian installations and crashes...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-14 20:38 EDT by Doncho N. Gunchev
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 09:51:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-05-14 20:38:18 EDT
Description of problem:
The latest rawhide shows wrong keyboard layout list for Bulgarian installations
and crashes if ru_win is selected.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.58-1

How reproducible:
Tried two times - both.

Steps to Reproduce:
1. Try installing fedora 7 (rawhide) from mirrors.kernel.org with virt-manager
and qemu emulation.
2. Select Bulgarian
3. Select ru_win keyboard layout
  
Actual results:
The system crashes saying it can not find the keyboard layout if ru_win is selected.

Expected results:
Anaconda should present bg_phonetic and bg_bds layouts (and en_us) and continue
without errors.

Additional info:
May be related to Bug # 238345.
Comment 1 Jeremy Katz 2007-05-15 11:01:56 EDT
How does it crash?
Comment 2 Doncho N. Gunchev 2007-05-15 12:27:31 EDT
It complained that some file is missing and displayed a debug dialog. I'll try 
this again and give more details.
Comment 3 Doncho N. Gunchev 2007-05-15 13:22:20 EDT
I can not attach the screenshot of this, so I'll explain. The crash happens long
after the keyboard is selected  - when stage2.img has been downloaded and
executed. This is run with virt-manager and qemu.
At the screen (after I selected 'debug') there is:
--- cut ---
Изпълнение на анаконда, Fedora системен инсталатор - моля изчакайте...
Probing for video card:    Cirrus Logic GD 5446
Attempting to start native X server
Waiting for X server to start...log located in /tmp/ramfs/X.log
1...2...3...4...5... X server started sccessfully.
Стартиране на инсталацията в графичен режим...
Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/rhpl/keyboard.py", line 131, in activat
e
    kbd = self.modelDict[console_kbd]
  File "/usr/lib/anaconda/gui.py", line 985, in run
    anaconda.id.keyboard.activate()
  File "/usr/bin/anaconda", line 955, in <module>
    anaconda.intf.run(anaconda)
KeyError: 'ru_win'

Entering debugger...
> /usr/lib/python2.5/site-packages/rhpl/keyboard.py(131)activate()
-> kbd = self.modelDict[console_kbd]
(Pdb) _
--- cut ---
hope this helps...
Comment 4 Chris Lumens 2007-05-16 12:59:04 EDT
Please try the next rawhide tree with rhpl-0.206-1 and anaconda-11.2.0.60 in it
and let me know if this is working better for you.
Comment 5 Doncho N. Gunchev 2007-05-19 07:05:23 EDT
stage2.img from 2007-May-18 19:41:09 - hashlib.py line 34 can't import
_sha256... waiting for the next image. Any hint from where to get them sooner
(boot.iso + stage2.img)?
Comment 6 Doncho N. Gunchev 2007-05-28 14:25:40 EDT
With boot.iso from 27-May-2007 05:35 the problem is still the same (there's no
Bulgarian kbd and ru_win crashes anaconda). rhpl-0.208-1 + 
system-config-keyboard-1.2.11-1.fc7 work correct (Bulgarian + Bulgarian
Phonetic) in my F7 rawhide (Bug # 238345 is fixed).
Comment 7 Doncho N. Gunchev 2007-06-03 07:16:51 EDT
No change with F7 final (qemu -m 480 -cdrom boot.iso -boot d). With 'qemu -m 480
-hda diskboot.img -boot c' I get:
Loading vmlinuz.......
Loading initrd.img......_
and the cursor stays forever after the dots (more dots than I typed here).
Comment 8 Doncho N. Gunchev 2007-07-04 03:20:51 EDT
No change, tried the latest FC8 images and even the line numbers are the same. 
No bg/bg_pho options and still crashing with Bulgarian + ru_win.
Comment 9 Chris Lumens 2007-07-20 14:40:43 EDT
Of course we keep this sort of information in more than one place!  Please try a
future tree with anaconda-11.3.0.9 in it, which I have not built yet.  This
should have updated keymaps for the loader that reflect the earlier changes I
made in rhpl.
Comment 10 Doncho N. Gunchev 2007-09-29 06:36:45 EDT
I tested rawhide today.

In the text anaconda interface I can see both layouts and they seem to work.

In the graphical anaconda interface for the keyboard I have the following 
choices: 'Български' (Bulgarian, translated) and 'Bulgarian (Phonetic)', which 
is on the top. I searched all .pot files I have and can't find this string for 
translation but it looks working.

Can't crash the installer any more.

Note You need to log in before you can comment on or make changes to this bug.