Bug 240097 - k3b compains about cdrecord and other programs not having root permissions
Summary: k3b compains about cdrecord and other programs not having root permissions
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-15 06:00 UTC by Valent Turkovic
Modified: 2008-01-17 13:20 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 13:20:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Valent Turkovic 2007-05-15 06:00:18 UTC
Description of problem:
When I start k3b it complains every time that cdrecord, cdrdao and growisofs
don't have root permissions and that the burning without root permissions isn't
advised because with root permissions it runs with high priority which increases
the overall stability of the burning process.

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. run k3b
2.
3.
  
Actual results:
k3b complains

Expected results:
I wan't the most stabillity I can get when burning dvd's and cd's and k3b just
complains. I feel like fedora team can give root permissions to these files
automatically when k3b is installed. Or at least give us some option during the
install to click "I wan't more stable burning by giving there programs root
permissions: cdrecord..."

I fixed it manuallay by:
chmod 4711 /usr/bin/cdrdao
chmod 4711 /usr/bin/growisofs
chmod 4711 /usr/bin/cdrdao

In previous versions of k3b there was the program k3bsetup that did this.
I can't find it on my system so I guess it is not shipped with fedora for some
reason.

Additional info:
k3b 1.0 running on fedora 7 test 4 with all updates.

ps. I believe that this bug is also present on Fedora Core 6

Comment 1 Valent Turkovic 2007-12-29 19:37:40 UTC
I havent seen this in fedora 8 so I believe this can be closed.


Note You need to log in before you can comment on or make changes to this bug.