Bug 240105 - aic94xx unable to load firmware during boot
aic94xx unable to load firmware during boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 04:29 EDT by Don Scales
Modified: 2008-06-16 21:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Scales 2007-05-15 04:29:29 EDT
Description of problem:
aic79xx 1.0.2 in fc6 2.6.18-1.2798 does not load microcode or work with 
Adaptec AIC-9410W SAS/SATA Host Adapter
aic79xx 1.0.2 in fc6 2.6.20-1.2948 does load micorcode and does work with
Adaptec AIC-9410W SAS/SATA Host Adapter but only if the system is booted
using a different boot disk.
There are two problems here.
1) mkinitrd does not put the /lib/firmware files into initrd
2) if the /lib/firmware file (aic94xx-seq.fw) required by aic94xx
is put into the initrd image manually, then when aic94xx is loaded by
the init nash script, aic94xx can't load the firmware file
aic94xx: Failed to load sequencer firmware file aic94xx-seq.fw, error -2

Once the system has loaded, rmmod aic94xx followed by modprobe aic94xx
correctly loads aic94xx

Looking at aic94xx code, only the firmware name is passed to the
request_firmware routine. Think this might be part of firmware_class.c
in drivers/base but not able to make much sense of this code.

Version-Release number of selected component (if applicable):
fc6 2.6.20-1.2948

How reproducible:
boot system that has aic94xx in the initrd image

Steps to Reproduce:
1.Find system with Adaptec AIC-9410W SAS/SATA Host Adapter
2.Add SCSI adapter and disk and build system on this disk
3.Run mkinitrd having checked that aic94xx is in modprobe.conf
  
Actual results:
aic94xx: Failed to load sequencer firmware file aic94xx-seq.fw, error -2

Expected results:
aic94xx: using sequencer V30
scsi 3:0:0:0: Direct-Access     FUJITSU  MAX3073RC        0104 PQ: 0 ANSI: 3


Additional info:
Suggestions on a quick fix would be helpful as I really don't want
to use external disks with this system.
Comment 1 Don Scales 2007-06-19 05:49:34 EDT
Tested Fedora Core 7 on same machine - still can't see the disks.
So - unable to install or boot fc6 or fc7 on a machine the requires
the Adaptec aic94xx driver to access the SAS disks !
Comment 2 WolfgangS 2007-09-07 13:35:43 EDT
Exchanging the "insmod aic94xx" in the init nash script with "modprobe aic94xx"
allows loading of the firmware during boot.

Unfortunately this doesn't work during initial install as there is no nash script.
Comment 3 Toni Harbaugh-Blackford 2007-10-01 07:59:41 EDT
This is still a problem with fedora as of 10/01/07, kernel 2.6.23-0.214.rc8.git2.fc8

running mkinitrd includes the aic94xx firmware in /lib/firmware in the
initrd, but the firmware is not loaded during boot so disks attached
to the aic94xx are not detected.
Comment 4 Peter Jones 2007-10-01 12:38:42 EDT
Toni, can you move the files in the initrd in /lib/firmware to /firmware,
reassemble the firmware, and try that?
Comment 5 Toni Harbaugh-Blackford 2007-10-01 12:57:28 EDT
Peter-

I tried coping /lib/firmware to /firmware (leaving the original
/lib/firmware in place), and I also tried moving
/lib/firmware to /firmware (so that /lib/firmware would not
be present).  Unfortunately neither worked.  I continue to get the
following error when the aic94xx module loads:

.
.
.
Loading scsi_transport_sas.ko module
Loading libsas.ko module
Loading aic94xx.ko module
aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
ACPI: PCI Interrupt 0000:04:02.0[A] -> GSI 16 (level, low) -> IRQ 16
aic94xx: found Adaptec AIC-9410W SAS/SATA Host Adapter, device 0000:04:02.0
scsi4 : aic94xx
aic94xx: Failed to load sequencer firmware file aic94xx-seq.fw, error -2
aic94xx: couldn't init seqs for 0000:04:02.0
aic94xx: couldn't init the chip
ACPI: PCI interrupt for device 0000:04:02.0 disabled
aic94xx: probe of 0000:04:02.0 failed with error -2
.
.
.

should I try putting the firmware file directly in the root?

Thanks,
Toni
Comment 6 Toni Harbaugh-Blackford 2007-10-01 13:08:14 EDT
I went ahead and tried putting the firmware at the root, but that didn't work
either.  FYI, the firmware *does* load from /lib/firmware when the machine is
fully up.  It only fails to load during the initrd phase.

Toni
Comment 7 Johannes Walch 2007-12-28 05:50:34 EST
(In reply to comment #2)
> Exchanging the "insmod aic94xx" in the init nash script with "modprobe 
aic94xx"
> allows loading of the firmware during boot.
> Unfortunately this doesn't work during initial install as there is no nash 
script.

I could not reproduce this, in fact it doesn´t seem to load the module at all 
if I replace the insmod command with the modprobe command. modprobe is a 
symbolic link to nash by the way.
Comment 8 Johannes Walch 2008-01-02 10:23:46 EST
I did some more research on this issue. Turns out that udev is responsible for
loading the firmware when the driver is loaded, actually by simply writing the
firmware file to a /sys file using cat (firmware.sh does that in a live system). 

Fedora initrd does not run udevd, though only a very basic part of it, the
hotplug function of nash. So loading the driver obviously works once the system
is up and the whole udev environment is in place. Unfortunately the
documentation to nash is rather old and incomplete and digging through the
source code is difficult at best.

There seems to be a way to compile nash in a certain "debug" mode. I will
explore that and report back with more information.
Comment 9 Johannes Walch 2008-01-03 11:25:20 EST
I finally found out that this bug is acutally them same as this one
https://bugzilla.redhat.com/show_bug.cgi?id=378651. Have a look there what the
issue is.

Comment 10 Toni Harbaugh-Blackford 2008-01-03 13:11:15 EST
Yes the issue in
https://bugzilla.redhat.com/show_bug.cgi?id=378651
does sound like the same thing.  So will the prospective fix make it
into the development tree any time soon?
Comment 11 IBM Bug Proxy 2008-03-04 14:00:28 EST
------- Comment From jon.thomas@us.ibm.com 2008-03-04 13:57 EDT-------
Hi Redhat,

Any update? will the fix make it into the tree?
Comment 12 IBM Bug Proxy 2008-05-12 12:00:41 EDT
------- Comment From graham_eames@uk.ibm.com 2008-05-12 11:59 EDT-------
This issue seems to still be present in Fedora 9 GA - any further updates on the
fix?
Comment 13 Bug Zapper 2008-05-14 08:14:24 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Edouard Bourguignon 2008-06-02 04:42:54 EDT
This bug seems to be a regression, the Adaptec AIC-9410W SAS/SATA Host Adapter
works fine here on a RHEL AS4...
Comment 15 Bug Zapper 2008-06-16 21:19:24 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.