Bug 240136 - ldap address book broke from bad rpm package script after upgrade
ldap address book broke from bad rpm package script after upgrade
Status: CLOSED DUPLICATE of bug 240111
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 09:38 EDT by Brian Millett
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 10:44:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2007-05-15 09:38:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):
openldap*-2.3.30-2.fc6

How reproducible: every time an upgrade is done


Steps to Reproduce:
1. yum update
2. update the openldap packages
3. fix ldap
  
Actual results:

The ldap is not populated with the upgrade.ldif file so the database is empty.

Expected results:

should work correctly.

Additional info:

It looks like the scripts are bad for the openldap-server.  The preuninstall
works fine and the upgrade.ldif file is generated.  The old database files are
saved in the rpmorig/ directory, however the post install does not work because
the slapd is running so the line
/sbin/runuser -m -s /usr/sbin/slapadd -- "ldap" -l /var/lib/ldap/upgrade.ldif
>/dev/null 2>&1
fails, but the error is swalled up and not seen.  The slapadd needs the slapd to
NOT be running, so it needs to be turned off, then restarted.

After the upgrade, I need to stop ldap, slapadd the upgrade.ldif, restart ldap
and all is well.
Comment 1 Jan Safranek 2007-05-15 10:44:24 EDT

*** This bug has been marked as a duplicate of 240111 ***

Note You need to log in before you can comment on or make changes to this bug.