This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 240146 - Kernel panic after logging out of an iSER target
Kernel panic after logging out of an iSER target
Status: CLOSED DUPLICATE of bug 234352
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.0
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 10:51 EDT by Maarten van Malland
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 11:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Maarten van Malland 2007-05-15 10:51:11 EDT
Description of problem:

When you want to log out of an iSER target (iSCSI RDMA) the kernel crashes. 

Version-Release number of selected component (if applicable):

RHEL5 all versions

How reproducible:

Setup an iSCSI initiator/target connection with iSER and try to log out.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Christie 2007-05-15 13:54:31 EDT
We were doing a iser udpate for 5.1. I think it fixed this logout bug. I am
adding the iser maintainer to make sure.
Comment 2 Maarten van Malland 2007-05-16 04:33:49 EDT
Ok, very nice to have this bug confirmed. Is it perhaps possible for us to get 
an update/patch or another workaround when it's going to be tested? We're 
working with this quite alot, so it would be very nice to have access to some 
beta version. Thank you very much in advance.
Comment 3 Maarten van Malland 2007-05-16 04:55:06 EDT
Ok, very nice to have this bug confirmed. Is it perhaps possible for us to get 
an update/patch or another workaround when it's going to be tested? We're 
working with this quite alot, so it would be very nice to have access to some 
beta version. Thank you very much in advance.
Comment 4 Mike Christie 2007-05-16 12:45:14 EDT
Let us know if this patch
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=154068
from this bugzilla
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=234352
fixes your problem.

Do need instructions on how to build Red Hat kernels? This patch should work
with the rhel 5.0 kernel source or you can get the current development kernel
http://people.redhat.com/dzickus/el5/
Comment 5 Maarten van Malland 2007-05-18 02:56:22 EDT
Unfortunately when i try to download the patch i get this:

Access Denied
You are not authorized to access bug #234352. 

I'm still very interested to try this patch though.
Comment 6 Mike Christie 2007-05-18 11:08:55 EDT
(In reply to comment #5)
> Unfortunately when i try to download the patch i get this:
> 
> Access Denied
> You are not authorized to access bug #234352. 
> 

Sorry about that. I opened the bug so everyone can see the patches and comment
on the bug.
Comment 7 Maarten van Malland 2007-05-21 07:29:45 EDT
Yes indeed, this patch works just fine! I hope it will be included in the next 
release of RHEL5. 
Comment 8 Mike Christie 2007-05-21 11:55:47 EDT
Thanks for testing. We have it planned for 5.1.

*** This bug has been marked as a duplicate of 234352 ***

Note You need to log in before you can comment on or make changes to this bug.