Bug 240147 - broken layout of the Send/Receive dialog
Summary: broken layout of the Send/Receive dialog
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-15 14:52 UTC by Matthias Clasen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: evolution-2.10.1-16.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 03:35:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (400.33 KB, image/png)
2007-05-15 14:53 UTC, Matthias Clasen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 335241 None None None Never

Description Matthias Clasen 2007-05-15 14:52:36 UTC
I see a horizontal scrollbar, and the buttons are half cut off.

Comment 1 Matthias Clasen 2007-05-15 14:53:51 UTC
Created attachment 154743 [details]
screenshot

Comment 2 Matthias Clasen 2007-05-15 15:26:31 UTC
Manually resizing the dialog does not fix this problem, next time the dialog is
too small again.

Comment 3 Matthew Barnes 2007-05-15 15:40:01 UTC
The dialog apparently has a hardcoded limit of 750 x 400 pixels.  I can see the
rationale for wanting to limit the size of the dialog but hardcoded numbers
doesn't feel like the right way to do it.  Maybe use a percentage of the screen
dimensions?  Other suggestions?

Also, this seems like a packing issue as well.  The contents of the dialog is
packed into a GtkTable and every cell has 'xoptions' of GTK_EXPAND | GTK_FILL.
Seems like one of the columns should shrink when the dialog hits its max width;
perhaps the progress bar since it doesn't accurately show progress anyway.

Not familiar enough with packing and GtkTables to know how to fix this off-hand,
but I'll play around with it.

Comment 4 Matthew Barnes 2007-05-15 15:41:44 UTC
I forgot to mention that the limit is enforced when a "map-event" signal is
emitted.  It does a gtk_widget_set_size_request() on the dialog.

Comment 5 Matthias Clasen 2007-05-15 15:48:05 UTC
You probably need to ellipsize the labels if you want to enforce any hard limit

Comment 6 Matthew Barnes 2007-05-15 18:20:54 UTC
Proposed a solution here, followed by a patch:
http://bugzilla.gnome.org/show_bug.cgi?id=335241#c27

If I put it in Rawhide can you test it before the hard freeze Thursday?

Comment 7 Matthias Clasen 2007-05-15 18:59:32 UTC
Sure

Comment 8 Matthew Barnes 2007-05-15 19:57:54 UTC
Fixed (I think) in evolution-2.10.1-16.fc7.

Comment 9 Matthias Clasen 2007-05-16 02:42:24 UTC
Fix works perfectly.

Comment 10 Matthew Barnes 2007-05-16 03:35:27 UTC
Good!  I'll close this then and hope that upstream is receptive to my solution.


Note You need to log in before you can comment on or make changes to this bug.