Bug 24015 - Apache 1.3.9 doesn't build under Redhat 7
Summary: Apache 1.3.9 doesn't build under Redhat 7
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-15 05:05 UTC by Sonam Chauhan
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-15 05:05:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sonam Chauhan 2001-01-15 05:05:04 UTC
I've built Apache 1.3.9 before many times with the following flags. 
   ./configure     --enable-shared=max    --enable-module=most 

However it fails under Redhat 7

Failure message
===========
Comment: ndbm.h and db.h both exist in /usr/include/db1/

--SNIP--
gcc -c  -I../../os/unix -I../../include   -DLINUX=2 -DNO_DBM_REWRITEMAP
-DUSE_HS
REGEX -DUSE_EXPAT -I../../lib/expat-lite `../../apaci` -fpic
-DSHARED_MODULE mod
_auth_anon.c && mv mod_auth_anon.o mod_auth_anon.lo
gcc -shared -o mod_auth_anon.so mod_auth_anon.lo
gcc -c  -I../../os/unix -I../../include   -DLINUX=2 -DNO_DBM_REWRITEMAP
-DUSE_HS
REGEX -DUSE_EXPAT -I../../lib/expat-lite `../../apaci` -fpic
-DSHARED_MODULE mod
_auth_dbm.c && mv mod_auth_dbm.o mod_auth_dbm.lo
In file included from mod_auth_dbm.c:79:
/usr/include/db1/ndbm.h:42:16: db.h: No such file or directory
make[4]: *** [mod_auth_dbm.so] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
--SNIP--


OS
===
Redhat 7 (Linux 2.2.16-22 )

Comment 1 Nalin Dahyabhai 2001-01-18 21:39:14 UTC
Per email, user has solved the problem.

Comment 2 Sonam Chauhan 2001-01-18 22:10:20 UTC
Apache 1.3.9 does not build because it can't find <db.h>. 
RedHat ha moved db.h to under /usr/include/db1 in RH 7 
The gcc version reported by Redhat 7: Wonder if it's related to 
http://gcc.gnu.org/gcc-2.96.html

Put an extra include in the build process to get it working.... 
(set "EXTRA_INCLUDES=-I/usr/include/db1" in apache_1.3.9/src/Configuration.tmpl) 





Note You need to log in before you can comment on or make changes to this bug.