Bug 240220 - krb5: krb5-config --libs krb5 includes -lkeyutils
Summary: krb5: krb5-config --libs krb5 includes -lkeyutils
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: krb5   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-15 19:49 UTC by Rex Dieter
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 20:27:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to omit extra libs from krb5-config (373 bytes, patch)
2007-05-15 20:43 UTC, Rex Dieter
no flags Details | Diff

Description Rex Dieter 2007-05-15 19:49:05 UTC
krb5-config --libs krb5 (now) includes -lkeyutils

Which leads to build failures for anything that
BuildRequires: krb5-devel

So, either strip -lkeyutils from krb5-config or add to krb5-devel:
Requires: keyutils-libs-devel

(i can fix it for you if you want, just let me know).

Comment 1 Nalin Dahyabhai 2007-05-15 19:52:48 UTC
If you can get to it before me, please go ahead and strip it from the
krb5-config output.  Since we don't currently support static linking, and the
keyutils library is used in a manner which is mostly hidden from applications
which use libkrb5, that's probably the simpler thing to do.  Thanks!

Comment 2 Rex Dieter 2007-05-15 19:57:47 UTC
Sure, will do.

Comment 3 Rex Dieter 2007-05-15 20:41:37 UTC
Arg,
**** Access denied: rdieter is not in ACL for rpms/krb5/devel

I'll attach the patch

Comment 4 Rex Dieter 2007-05-15 20:43:21 UTC
Created attachment 154777 [details]
patch to omit extra libs from krb5-config

Comment 5 Nalin Dahyabhai 2007-05-16 20:27:52 UTC
Thanks!  Incorporating for 1.5-6.


Note You need to log in before you can comment on or make changes to this bug.