Bug 240231 - nautilus uses all swap after 1 week - hangs machine
nautilus uses all swap after 1 week - hangs machine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
7
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-15 17:21 EDT by Kyle
Modified: 2014-06-18 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: gnome-desktop-2.18.3-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 17:19:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle 2007-05-15 17:21:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.3) Gecko/20070417 Fedora/2.0.0.3-4.fc7 Firefox/2.0.0.3

Description of problem:
I keep the system monitor applet up in my gnome session showing me swap usage.  Over only one or two days, swap starts to get utilized (not necessarily a bad thing).  As the days progress, however, swap usage continually grows.  When I do a 'top' and press 'F', 'p' to sort by SWAP, nautilus is always at the top.  I left my machine running for 1 week, after which nautilus was using all of my 2G swap!  The machine came to a crawl and I had to press the reset button to revive it.

Version-Release number of selected component (if applicable):
nautilus-2.18.1-2.fc7

How reproducible:
Always


Steps to Reproduce:
1. Leave the machine running for a 2-7 days

Actual Results:
Swap space is continually eaten by nautilus

Expected Results:
Nautilus shouldn't run away with all my memory ;-)

Additional info:
uname -a:
Linux <myhostname> 2.6.21-1.3142.fc7 #1 SMP Mon May 7 21:07:42 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

Asus P5NSLI Motherboard
1.86GHz Intel Core 2 Duo Processor
1GB (512x2) DDR2 memory
Nvidia GeForce 7300 LE (128 MB) Graphics Card

# cat /proc/swaps 
Filename                                Type            Size    Used    Priority
/dev/sda2                               partition       2032212 776552  -1
Comment 1 Kyle 2007-05-15 17:37:15 EDT
One other note I forgot, just in case it helps - this was an FC6 box that I
upgraded to FC7T3 about 4 weeks ago and have kept up-to-date with the following
yum repos:

[development]
name=Fedora Core - Development
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basearch

[extras-development]
name=Fedora Extras - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/development/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-devel&arch=$basearch

[livna-development]
name=Livna.org Fedora Compatible Packages (Development)
baseurl=http://rpm.livna.org/fedora/development/$basearch

[development-32bit]
name=Fedora Core - Development
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/development/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=i386

[extras-development-32bit]
name=Fedora Extras - Development Tree
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/extras/development/$basearch/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=extras-devel&arch=i386

[livna-development-32bit]
name=Livna.org Fedora Compatible Packages (Development)
baseurl=http://rpm.livna.org/fedora/development/i386

[flash]
name=macromedia.mplug.org - Flash Plugin
baseurl=http://macromedia.mplug.org/rpm/
        http://macromedia.rediris.es/rpm/
failovermethod=priority

[skype]
name=Skype Repository
baseurl=http://download.skype.com/linux/repos/fedora/5/updates/i586/
Comment 2 Alexander Larsson 2007-05-21 04:54:32 EDT
Did you use nautilus during this time?
Comment 3 Kyle 2007-05-21 05:00:51 EDT
Nope.  I actually never use it to browse my files.  I always use the
gnome-terminal.  I notice the 'nautilus' process is always running, however.  I
guess it's also responsible for the icons on the desktop since doing a 'killall
-s HUP nautilus' makes the icons disappear and reappear.

I guess the summary of the bug should read:
nautilus *process* uses all swap after 1 week - hangs machine
Comment 4 Kyle 2007-06-11 15:32:34 EDT
Just to update this bug, I've since switched to the official F7 repos and kept
myself up-to-date from there instead of using rawhide.  After keeping myself
logged in over the weekend, here's what 'top' looks like:


top - 12:30:57 up 3 days, 20:02,  3 users,  load average: 0.54, 0.33, 0.20
Tasks: 172 total,   1 running, 170 sleeping,   0 stopped,   1 zombie
Cpu(s):  1.0%us,  0.2%sy,  0.0%ni, 98.5%id,  0.2%wa,  0.0%hi,  0.2%si,  0.0%st
Mem:   1026104k total,  1007456k used,    18648k free,     6568k buffers
Swap:  2032212k total,  1094968k used,   937244k free,   173964k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  SWAP COMMAND      
                                                                   
 2933 kylek     15   0 1533m 244m 7940 S    0 24.4   0:36.94 1.3g nautilus     
                                                                   
27638 kylek     15   0  834m 116m  23m S    1 11.6   0:52.90 718m firefox-bin  
                                                                   
 2953 kylek     15   0  729m  24m 9336 S    0  2.4  25:32.19 704m amarokapp    
Comment 5 Kyle 2007-06-11 15:35:36 EDT
After doing a 'killall -s HUP nautilus' here's what 'top' looks like (all 'top'
output given by me in this bug is sorted by swap; pressing 'F', 'p', 'Enter'
while running):

top - 12:34:04 up 3 days, 20:05,  3 users,  load average: 0.72, 0.40, 0.24
Tasks: 176 total,   2 running, 173 sleeping,   0 stopped,   1 zombie
Cpu(s):  0.8%us,  0.3%sy,  0.0%ni, 98.1%id,  0.5%wa,  0.0%hi,  0.3%si,  0.0%st
Mem:   1026104k total,   858244k used,   167860k free,    10408k buffers
Swap:  2032212k total,   291560k used,  1740652k free,   239932k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  SWAP COMMAND      
                                                                   
 2953 kylek     15   0  730m  24m 9152 S    0  2.5  25:33.10 705m amarokapp    
                                                                   
27638 kylek     15   0  814m 116m  23m S    0 11.6   0:57.25 698m firefox-bin  
                                                                   
 2946 kylek     15   0  681m  15m  10m S    0  1.6   0:01.68 666m pidgin      
Comment 6 Kyle 2007-08-16 13:23:21 EDT
I've noticed that this really only happens when I change my background image
often.  I have Wallpaper Tray 0.5.3 (wp_tray) running on my Gnome panel. 
Whenever I tell it to automatically switch my background multiple times a day
(usually every 30-60 minutes), I see the swap issue.  When I turn off the
automatic background switching (so I look at the same image all day), swap use
is greatly minimized.

Could this indicate that there's an issue with the transparency of the desktop
icons or their labels?
Comment 7 Matthias Clasen 2007-10-02 23:56:50 EDT
Soren, do we need to backport your recent gnome-bg memleak fixes to F-7 ?
Comment 8 Fedora Update System 2007-10-08 10:58:41 EDT
gnome-desktop-2.18.3-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-desktop'
Comment 9 Kyle 2007-10-09 13:32:22 EDT
I updated to gnome-desktop-2.18.3-3.fc7 as suggested in comment 8 yesterday, and
so far so good.  I re-enabled the automatic background switching in wp_tray for
every 30 minutes and left it running over night.  Swap being used by the
nautilus process was the same when I came in this morning.

This is only 1 day though, so I'll keep an eye on it for the next couple of days
and update this bug with my findings.
Comment 10 Søren Sandmann Pedersen 2007-12-11 17:19:09 EST
I assume this was fixed.
Comment 11 Kyle 2007-12-12 06:45:59 EST
Yes, sorry.  Everything has been behaving MUCH better since the latest release.
 Thanks!

Note You need to log in before you can comment on or make changes to this bug.