Bug 240240 - Linker errors on HP-UX using LDAP C SDK 6.0.3
Summary: Linker errors on HP-UX using LDAP C SDK 6.0.3
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Directory Server   
(Show other bugs)
Version: 1.0.4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 152373 240316 FDS1.1.0
TreeView+ depends on / blocked
 
Reported: 2007-05-15 23:28 UTC by Nathan Kinder
Modified: 2015-12-07 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 16:51:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs (1.24 KB, patch)
2007-05-15 23:28 UTC, Nathan Kinder
no flags Details | Diff

Description Nathan Kinder 2007-05-15 23:28:23 UTC
When building HEAD of ldapserver on HP-UX with v6.0.3 of the LDAP C SDK, linker
errors are reported when linking libslapd.so and libds_admin.so.

These errors are caused by a change in the libraries that libldap.so is linked
to in v.6.0.3.  The libldap.so library has a dependency on libsasl2.so, so we
need to link to libsasl2.so from anything that we link to libldap.so.

Comment 1 Nathan Kinder 2007-05-15 23:28:23 UTC
Created attachment 154785 [details]
CVS Diffs

Comment 2 Nathan Kinder 2007-05-15 23:38:24 UTC
Checked into HEAD.  Thanks to Noriko for the review!

Checking in Makefile.am;
/cvs/dirsec/ldapserver/Makefile.am,v  <--  Makefile.am
new revision: 1.38; previous revision: 1.37
done
Checking in Makefile.in;
/cvs/dirsec/ldapserver/Makefile.in,v  <--  Makefile.in
new revision: 1.45; previous revision: 1.44
done


Note You need to log in before you can comment on or make changes to this bug.