Bug 240256 - inkscape default window doesn't fit at 800x600
Summary: inkscape default window doesn't fit at 800x600
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-16 03:18 UTC by Jeremy Katz
Modified: 2008-03-30 11:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-30 11:06:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2007-05-16 03:18:01 UTC
If you're running on a screen with only a resolution of 800x600 (as is common
for virtual machines), then the inkscape window doesn't fully fit.

Easy to test out
  xrandr -s 800x600
  inkscape

Comment 1 Denis Leroy 2007-05-16 08:43:14 UTC
Not a whole lot I can do on this one. Filed upstream at 

http://sourceforge.net/tracker/index.php?func=detail&aid=1719858&group_id=93438&atid=604306

though i wouldn't expect a quick response. I might close as WONTFIX if i don't
hear anything from above... Did you know VMWare WS can adjusts the resolution of
a Linux guest OS dynamically as you're resizing the window on the host ? It's
pretty neat. Or is this happening with Xen VMs ?


Comment 2 Jeremy Katz 2007-05-16 13:05:51 UTC
Pretty sure VMware doesn't do that, but it's been a while since I've poked at
it.  This is with qemu/xen/kvm.  But I know that VMware will come up as 800x600
by default due to a lack of monitor EDID info.  

It seems a little thing, but lots of reviewers end up testing in environments
like this and if we're going to have inkscape on the default live image, then we
probably do want to get this fixed if we can.  If you need some help working on
a fix, let me know and I'll try to carve a little bit of time up to poke at it
or ask on fedora-devel-list

Comment 3 Denis Leroy 2007-05-16 15:35:09 UTC
VMWare has supported randr resize since 5.0 (or is it 5.5?), though you need to
compile the guest toolbox, which requires the any-any patch on FC-6. I use
workstation 5.5.4 a lot on FC-6 host to test my fc-5 and fc-7 packages. Just
maximize the console window and bam the guest resizes automatically.

Anyways. The windows size limitation here are the horizontal and vertical
toolbars. Since this is gnome, you can drag them out of the window which will 
then let you resize the window down to the menu width. To have the toolbars
"compressible" (as in thunderbird for example, the masked toolbar buttons become
available in a small submenu on the right of the toolbar) will require some
non-trivial gtk hackage to improve the custom widgets inkscape is using for
their toolbars. I don't think they use the standard GtkToolbar (it's
compressible by default, but has many undesirable restrictions). I think this
discussion needs to happen on the upstream mailing list, let me post something
quick.


Comment 4 Denis Leroy 2007-05-18 11:25:47 UTC
Update: upstream bug is

http://sourceforge.net/tracker/?func=detail&aid=1469554&group_id=93438&atid=604306


Comment 5 Lubomir Kundrak 2008-02-15 09:50:42 UTC
In 0.46pre1 the window doesn't fit even into 1024x768.
https://bugs.launchpad.net/fedora/+source/inkscape/+bug/168648

Comment 6 Denis Leroy 2008-02-15 10:16:35 UTC
This should probably be closed as WONTFIX


Comment 7 Lubomir Kundrak 2008-03-30 11:06:57 UTC
Inkscape windows fits to 1024x768 with small icons (default in Fedora).
800x600 will only be fixed if someone implements collapsing of vertical
toolbars, similar to ones present for horizontal ones (being discussed upstream).
If you really need to run it at 800x600, detach the vertical toolbar.


Note You need to log in before you can comment on or make changes to this bug.