Bug 240295 - Update 5 messes up imap configuration
Update 5 messes up imap configuration
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 08:15 EDT by dijuremo
Modified: 2010-03-05 10:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-05 10:02:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dijuremo 2007-05-16 08:15:08 EDT
Description of problem:

Using up2date to apply Update 5 installes the new cyrus imap server which does
not care about existing configuration files. The following existing and
currently used files

/etc/imapd.conf
/etc/cyrus.conf

Get moved to .rpmsave versions and new clean versions with no configurations are
then placed under /etc, messing up the imap server configuration.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Have cyrus-imapd configured on a RHEL4.4 system
2. Update to RHEL4.5 with up2date -u
3. Now the imap server is not working since the configuration files were moved
Comment 1 dijuremo 2007-05-16 08:32:01 EDT
I forgot to say that the warning is mentioned during the update, but if the file
is there, shouldn't it just save the clean configuration files as rmpnew? rather
than move the current ones to rpmsave?

189:cyrus-imapd            warning: /etc/cyrus.conf saved as /etc/cyrus.conf.rpmsave
warning: /etc/imapd.conf saved as /etc/imapd.conf.rpmsave
warning: /etc/pam.d/imap created as /etc/pam.d/imap.rpmnew
warning: /etc/pam.d/sieve created as /etc/pam.d/sieve.rpmnew

The other thing is that it may be a specific problem to my configuration since
the imapd.conf and cyrus.conf file are in fact symbolic links to the actual
configuration files that are in a drbd mounted partition.
Comment 3 Dan Horák 2008-08-15 05:21:46 EDT
yeah, noreplace is missing for these config files in the spec file
Comment 4 RHEL Product and Program Management 2008-10-31 12:41:29 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 5 Michal Hlavinka 2010-03-05 10:02:27 EST
I'm sorry for not addressing the issue in RHEL-4. As cyrus-imapd
is not scheduled for update in RHEL-4.9, I'm closing that bugzilla WONTFIX. If
you are still experiencing the issue with RHEL-5, feel free to reopen it
against RHEL-5.

Note You need to log in before you can comment on or make changes to this bug.