Bug 240351 - recent vorbis-tools upgrade dropped http support
recent vorbis-tools upgrade dropped http support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vorbis-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 13:17 EDT by Christopher Aillon
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: vorbis-tools-1.1.1.svn20070412-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 16:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Aillon 2007-05-16 13:17:30 EDT
Description of problem:
We recently updated to a snapshot version of vorbis-tools to pull in flac again.
 However, that broke http support for e.g. ogg123.  After some debugging, it
appears this is because #define HAVE_FLAC 1 is no longer getting set in config.h
even if curl-devel is installed and configure finds it.  We're missing an
AC_DEFINE it appears.

Patch to configure.ac fixes it:

--- vorbis-tools-1.1.1.svn20070412/configure.ac.libcurl 2007-05-16
13:04:09.000000000 -0400
+++ vorbis-tools-1.1.1.svn20070412/configure.ac 2007-05-16 12:56:40.000000000 -0400
@@ -165,6 +165,9 @@ if test "x$HAVE_PKG_CONFIG" = "xyes"; th
 else
   AM_PATH_CURL(HAVE_CURL=yes, HAVE_CURL=no; AC_MSG_WARN(libcurl missing))
 fi
+if test "x$HAVE_CURL" = "xyes"; then
+  AC_DEFINE(HAVE_CURL,1,[Defined if we have libcurl])
+fi
 
 if test "x$build_ogg123" = xyes; then
   AC_MSG_RESULT([checking for ogg123 requirements])
Comment 1 Christopher Aillon 2007-05-16 14:33:00 EDT
(I meant HAVE_CURL was not getting set in config.h)
Comment 2 Christopher Aillon 2007-05-16 16:28:02 EDT
vorbis-tools-1.1.1.svn20070412-2.fc7

Note You need to log in before you can comment on or make changes to this bug.