Bug 240353 - TypeError: getMembers() takes at most 2 arguments (3 given)
Summary: TypeError: getMembers() takes at most 2 arguments (3 given)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 235611
TreeView+ depends on / blocked
 
Reported: 2007-05-16 17:56 UTC by Andrew Cagney
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 18:08:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
what anaconda dumped to a remote machine (52.39 KB, text/plain)
2007-05-16 17:58 UTC, Andrew Cagney
no flags Details

Description Andrew Cagney 2007-05-16 17:56:38 UTC
Description of problem:

When installing on ps3, either 6.93 or rawhide of today:

Traceback (most recent call first):
  File "/usr/lib/anaconda/sortedtransaction.py", line 33, in getMembers
    return TransactionData.getMembers(self, pkgtup, output_states)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1800, in install
   tx_return.extend(self.tsInfo.getMembers(pkgtup=po.pkgtup))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1448, in selectGroup
    txmbrs = self.install(name = pkg)
  File "/usr/lib/anaconda/yuminstall.py", line 1267, in selectGroup
    mbrs = self.ayum.selectGroup(group)
  File "/usr/lib/anaconda/installclasses/fedora.py", line 41, in <lambda>
    map(lambda x: anaconda.backend.selectGroup(x), grps)
  File "/usr/lib/anaconda/installclasses/fedora.py", line 41, in setGroupSelection
    map(lambda x: anaconda.backend.selectGroup(x), grps)
  File "/usr/lib/anaconda/backend.py", line 244, in doBasePackageSelect
    anaconda.id.instClass.setGroupSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1041, in nextClicked
    self.anaconda.dispatch.gotoNext()
TypeError: getMembers() takes at most 2 arguments (3 given)

Comment 1 Andrew Cagney 2007-05-16 17:58:46 UTC
Created attachment 154854 [details]
what anaconda dumped to a remote machine

Comment 2 Chris Lumens 2007-05-16 18:22:29 UTC
This should be fixed in anaconda-11.2.0.56-1.  What version is in the trees you
are trying?

Comment 3 Andrew Cagney 2007-05-16 18:59:22 UTC
rawhide of today (16th, date on directory was 15th), from
download.fedora.redhat.com/*/developement/*/ppc/

Comment 4 Chris Lumens 2007-05-16 19:46:00 UTC
What kind of install are you doing?  It doesn't look like there's any stage2
image in that tree, so I'm curious as to where that is coming from.  When
anaconda is starting up before it gets to graphical mode, you'll see a message
line "Greetings.  anaconda installer init version XXXXX starting".  What version
does it display?  This looks like tree weirdness to me, as we have certainly
fixed the code in question to where it no longer looks like what's displayed in
your traceback.

Comment 5 Andrew Cagney 2007-05-17 21:39:49 UTC
(In reply to comment #4)
> What kind of install are you doing?  It doesn't look like there's any stage2
> image in that tree, so I'm curious as to where that is coming from.  When
> anaconda is starting up before it gets to graphical mode, you'll see a message
> line "Greetings.  anaconda installer init version XXXXX starting".  What version
> does it display?  This looks like tree weirdness to me, as we have certainly
> fixed the code in question to where it no longer looks like what's displayed in
> your traceback.

Booting from a rawhide rescue disk; sounds like that is too old.  Will have to
twiddle thumbs until something more recent becomes available.

Mean while I've been given a workaround for getting this into text mode.

Comment 6 Jeremy Katz 2007-05-21 18:08:37 UTC
This is definitely fixed with current trees


Note You need to log in before you can comment on or make changes to this bug.