Bug 240385 - add /etc/xdg directories
add /etc/xdg directories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
: 248054 (view as bug list)
Depends On:
Blocks: wakeup F8Target
  Show dependency treegraph
 
Reported: 2007-05-16 18:04 EDT by Arjan van de Ven
Modified: 2009-09-21 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-14 11:14:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch (6.97 KB, patch)
2007-07-25 12:42 EDT, Matthias Clasen
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 476938 None None None Never

  None (edit)
Description Arjan van de Ven 2007-05-16 18:04:37 EDT
Description of problem:

strace -p `pidof gam_server`
shows that gnome is looking for a bunch of directories in /etc/xdg and in ~, for
menus. These aren't there by dfault, so gamin has to poll to see if they get
created.... redhat-menus should just create them...
Comment 1 Matthias Clasen 2007-05-17 13:33:02 EDT
Too late for f7 at this point. 

It is also probably better to fix gnome-menus to watch the parent directories
instead to spot when the directories are created - a bunch of these non-existing
directories are in ~ anyway, where we can't have packages creating random
directories.
Comment 2 Matthias Clasen 2007-07-24 22:46:49 EDT
*** Bug 248054 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Clasen 2007-07-25 12:42:55 EDT
Created attachment 159958 [details]
a patch
Comment 4 Matthias Clasen 2007-07-25 12:43:42 EDT
Here is a patch that might do the trick for gnome-menus; it is probably better
to do this in gamin itself.
Comment 5 Ray Strode [halfline] 2007-09-14 11:14:40 EDT
I built a gamin package that watches the directory parents until the directory
is not available.

Note You need to log in before you can comment on or make changes to this bug.