Bug 240388 - grub and or kernel bug
grub and or kernel bug
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
Depends On:
  Show dependency treegraph
Reported: 2007-05-16 19:27 EDT by Rob Strong
Modified: 2008-05-06 21:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 21:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rob Strong 2007-05-16 19:27:37 EDT
Description of problem:
Installing FC6 (test4) the soon to be FC7 on a Dell Optiplex 320.  After going
through a hassle to get the installation to work with a kernel option "acpi=off"
I was finally able to get the installion to begin.  Once the installation was
complete the system would not boot.  It seems to hang when GRUB passes the
kernel /vmlinuz command.  I tried this manually and confirmed that it does
indeed hang when you pass grub the kernel command.  It won't load the kernel to
save my life!

Version-Release number of selected component (if applicable):
FC6 (6.93) Test 4

How reproducible:
Every time.  Looks like the initial install saved the "acpi=off" option so it is
passed during boot.  I've tried it with a number of other options as well in
various combinations.

Steps to Reproduce:
1. boot system
2. c for grub command prompt and then pass the "kernel /vmlinuz.x.x.x


1. Just let it boot
Actual results:
Booting 'Fedora (2.6.20-2925.5.fc7xen)'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /xen.gz-2.6.20-2925.5.fc7
[Multiboot-elf, <0x100000 :0x966e4:0x5391c>

Expected results:
a running system

Additional info:
it just hangs at this point a locks up the keyboard and reports absolutely no
messages outside of this.  I have two kernels installed and tried booting from
both xen and the norm.  neither work and both do the same thing.  I can get into
the OS or filesystem in rescue mode but I have no idea what to do from there.  I
don't think a grub-install will work because grub seems to be functioning fine,
at least at the command prompt. The only other option is to try another kernel
but I don't know of any other versions aside from what's shipped with FC7. Let
me know if I can add any additional information.

Pentium 4 3 GHz
80 GB (seagate) SATA drive
512 Memory
Comment 1 Rob Strong 2007-05-16 19:48:51 EDT
I get this when booting the non xen kernel by selecting from the menu

booting 'Fedora-base (2.6.20-1.3104.fc7)'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.20-1.3104.fc7 ro root=/dev/vg01/root acpi=off rhgb quiet
[Linux-bzImage, setup=0x1e00, size=0x1da574]

Everything freezes as usual from this point!
Comment 2 Daniel Berrange 2007-05-16 22:34:23 EDT
FYI, the kernel-xen   2.6.20-2925.5.fc7xen build has 3 known *serious* data
corruption bugs, so it is not worth debugging on that kernel version. For Xen
please make sure you are using the latest rawhide trees - it is at least version
2.6.20-2925.8.fc7xen which has the data corruption bugs fixed.
Comment 3 Bug Zapper 2008-04-03 20:44:19 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Bug Zapper 2008-05-06 21:45:12 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.