Bug 240389 - Default handlers don't work anymore with 1.20
Default handlers don't work anymore with 1.20
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gpm (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Janousek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-16 19:29 EDT by Samuel Thibault
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.20.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 17:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
revert to good old behavior (1.04 KB, patch)
2007-05-16 19:29 EDT, Samuel Thibault
no flags Details | Diff
patch for version 1.20.1 (953 bytes, patch)
2007-05-16 19:48 EDT, Samuel Thibault
no flags Details | Diff

  None (edit)
Description Samuel Thibault 2007-05-16 19:29:08 EDT
Description of problem:
Default handlers (like the brltty daemon) don't work anymore with version 1.20 of gpm.

Version-Release number of selected component (if applicable):
1.20

How reproducible:
Always


Steps to Reproduce:
1. run brltty -b no -l 7 -n -e -x lx

Actual results:
notice the GPM errors about "Inappropriate ioctl for device"

Expected results:
There shouldn't be such error

Additional info:
This is because in Gpm_Open(), the flag<0 case isn't even treated in any particular way any more since version 1.20. The attached patch should fix that.
Comment 1 Samuel Thibault 2007-05-16 19:29:08 EDT
Created attachment 154882 [details]
revert to good old behavior
Comment 2 Samuel Thibault 2007-05-16 19:48:58 EDT
Created attachment 154885 [details]
patch for version 1.20.1

Oops, sorry, the attached patch was for version 1.20.2-broken. This one is for
1.20.1.
Comment 3 Tomas Janousek 2007-05-23 09:26:57 EDT
Ok, applied. I have the builds ready for f5/6/7/8, but will wait with the update
for the release of F7 and availability of the update system.
Comment 4 Fedora Update System 2007-06-04 17:27:09 EDT
gpm-1.20.1-84.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.