Bug 240402 - SpamAssassin sa-update gpg verification failure
SpamAssassin sa-update gpg verification failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-17 06:26 EDT by Anthony Messina
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 08:16:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anthony Messina 2007-05-17 06:26:46 EDT
Description of problem:
Each morning, I get a cron email stating that tht GPG verification of sa-update
failed because it was signed with the wrong key.  

Even after following the instructions provided in the email, the error continues
and the updates are not verified so they are not installed.

Version-Release number of selected component (if applicable):
spamassassin-3.1.8-2.fc6

How reproducible:
With every cron run

Steps to Reproduce:
1. Install spamassassin-3.1.8-2.fc6
2. Invoke the /etc/cron.d/sa-update script
  
Actual results:
An email is sent to <root> with the following content:
/etc/cron.daily/sa-update:

error: GPG validation failed!
The update downloaded successfully, but it was not signed with a trusted GPG
key.  Instead, it was signed with the following keys:

    24F434CE 

Perhaps you need to import the channel's GPG key?  For example:

    wget http://spamassassin.apache.org/updates/GPG.KEY
    sa-update --import GPG.KEY

channel: GPG validation failed, channel failed

Expected results:
I expect that after following the instructions and installing the GPG key, that
the next morning's updates would be processed without this same error.

Additional info:
I don't think it makes any difference here, but i do not run the spamassassin
daemon because i run amavisd-new which calls spamassassin directly.
Comment 1 Anthony Messina 2007-05-23 08:16:14 EDT
Closing this myself.  I erred in the report.

Note You need to log in before you can comment on or make changes to this bug.