Bug 240493 - rhn-applet fails to communicate w/ server
rhn-applet fails to communicate w/ server
Status: CLOSED DUPLICATE of bug 240386
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Shannon Hughes
Beth Nackashi
Depends On:
  Show dependency treegraph
Reported: 2007-05-17 16:33 EDT by wes hayutin
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-22 10:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2007-05-17 16:33:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061215 Red Hat/ Firefox/

Description of problem:
rhn-applet-2.1.25-15 on x86 rhel3_u9 does not work correctly or at all.

rhn-applet fails to communicate w/ the server 

[root@dhcp231-70 root]# rhn-applet-tui
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-tui", line 103, in ?
  File "/usr/bin/rhn-applet-tui", line 63, in main
    model = rhnAppletModelTUI(None, url, uuid)
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line 430, in __init__
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_source.py", line 35, in refresh
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 212, in _do_refresh
    status = server.applet.poll_status()
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 319, in _request
    request, verbose=self._verbose)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 168, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 694, in send_http
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 211, in connect
AttributeError: '_socket.socket' object has no attribute 'settimeout'

This also may be related to bug 240386.
The above SSL error may be due to the fact that its trying to connect to server_url=https://xmlrpc.rhn.redhat.com/APPLET
by default, and isnt updated when its registerd to a different server.

Version-Release number of selected component (if applicable):
rhn-applet-2.1.25-15 x86 only

How reproducible:

Steps to Reproduce:
see above

Actual Results:

Expected Results:

Additional info:
Comment 1 wes hayutin 2007-05-17 16:34:47 EDT
Red Hat Enterprise Linux AS release 3 (Taroon Update 9)
[root@dhcp231-70 root]# uname -a
Linux dhcp231-70.rdu.redhat.com 2.4.21-50.ELsmp #1 SMP Tue May 8 17:18:29 EDT
2007 i686 i686 i386 GNU/Linux
[root@dhcp231-70 root]# rpm -qa | grep rhn-applet
[root@dhcp231-70 root]#
Comment 2 wes hayutin 2007-05-22 10:34:11 EDT

*** This bug has been marked as a duplicate of 240386 ***

Note You need to log in before you can comment on or make changes to this bug.