Bug 240517 - conflict between kdebase and kde-settings-kdm
conflict between kdebase and kde-settings-kdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
: 240526 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-05-17 23:22 EDT by pete johnson
Modified: 2007-11-30 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 11:04:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pete johnson 2007-05-17 23:22:32 EDT
Description of problem:Installation of smb4k fails.


Version-Release number of selected component (if applicable):
smb4k.i386 0:0.8.2-1.fc7

How reproducible:/usr/bin/yum install smb4k


Steps to Reproduce:
1.
2.
3.
  
Actual results: yum determines which packages are necessary, then reports:

Total download size: 58 M
Is this ok [y/N]: y
Downloading Packages:
(1/21): libfreebob-1.0.3- 100% |=========================| 154 kB    00:00     
(2/21): kdnssd-avahi-0.1. 100% |=========================|  43 kB    00:00     
(3/21): kdelibs-3.5.6-7.f 100% |=========================|  18 MB    00:45     
(4/21): redhat-artwork-kd 100% |=========================| 559 kB    00:01     
(5/21): xorg-x11-xdm-1.1. 100% |=========================| 131 kB    00:00     
(6/21): libmng-1.0.9-5.1. 100% |=========================| 167 kB    00:00     
(7/21): jasper-1.900.1-1. 100% |=========================| 173 kB    00:00     
(8/21): lm_sensors-2.10.3 100% |=========================| 512 kB    00:01     
(9/21): OpenEXR-1.4.0a-3. 100% |=========================| 416 kB    00:00     
(10/21): kde-settings-3.5 100% |=========================|  15 kB    00:00     
(11/21): qt-3.3.8-4.fc7.i 100% |=========================| 3.6 MB    00:09     
(12/21): smb4k-0.8.2-1.fc 100% |=========================| 1.7 MB    00:04     
(13/21): jack-audio-conne 100% |=========================| 137 kB    00:00     
(14/21): nas-1.9-1.fc7.i3 100% |=========================| 647 kB    00:01     
(15/21): arts-1.5.6-3.fc7 100% |=========================| 1.1 MB    00:02     
(16/21): fltk-1.1.8-0.3.r 100% |=========================| 424 kB    00:00     
(17/21): htdig-3.2.0b6-11 100% |=========================| 1.0 MB    00:02     
(18/21): avahi-qt3-0.6.17 100% |=========================|  17 kB    00:00     
(19/21): kdebase-3.5.6-10 100% |=========================|  28 MB    01:10     
(20/21): freeglut-2.4.0-1 100% |=========================| 142 kB    00:00     
(21/21): kde-settings-kdm 100% |=========================|  15 kB    00:00     
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/config/kdm conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7

Expected results: smb4k would be installed


Additional info:I love samba.  Charles Dickens is a wonderful author.
Comment 1 David Kovalsky 2007-05-18 05:24:41 EDT
IMO this is the same dependency problem as bug 240526.
Comment 2 Bastien Nocera 2007-05-18 05:54:42 EDT
*** Bug 240526 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2007-05-18 05:56:07 EDT
More logs from upgrades in bug 240526
Comment 4 Ngo Than 2007-05-18 06:40:05 EDT
Rex, your new change caused the package conflict here. Could you please take a 
look and relsove the conflict. Thanks
Comment 5 Rex Dieter 2007-05-18 06:46:47 EDT
Yep, my bad, fixed.

* Wed May 16 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 6:3.5.6-11
- fix /usr/share/config/kdm conflict with kde-settings
Comment 6 Kevin Kofler 2007-05-18 06:54:47 EDT
I hope the fixed version is getting tagged f7-final ASAP. We sure don't want 
conflicts like that in the release.
Comment 7 Rex Dieter 2007-05-18 08:03:03 EDT
Than signed off on f7-final this morning.
Comment 8 Kevin Kofler 2007-05-18 09:31:28 EDT
But the tagging appears not to have happened yet:
https://koji.fedoraproject.org/koji/builds?prefix=k&tagID=10&order=-completion_time&inherited=1
and we're in deep freeze mode now. Doesn't this completely break the KDE live 
CD? If so, it is definitely an FC7Blocker!
Comment 9 Rex Dieter 2007-05-18 09:35:45 EDT
agreed.
Comment 10 Rex Dieter 2007-05-18 09:38:10 EDT
reopening, pending f7-final tagging.
Comment 11 Ngo Than 2007-05-18 11:01:53 EDT
i have talked with jeremy, he has already tagged kdebase-3_5_6-12_fc7 and 
kde-settings-3_5-26_fc7 for f7 final
Comment 12 Kevin Kofler 2007-05-18 11:04:38 EDT
Indeed, they show up in the list (URL from comment #8) now.
Comment 13 Valent Turkovic 2007-05-21 03:51:47 EDT
The bug is still present and prevents F7 updates!
This is a very serious bug!

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 kdebase                 i386       6:3.5.6-10.fc7   development        28 M
 kdelibs                 i386       6:3.5.6-7.fc7    development        18 M
Installing for dependencies:
 OpenEXR                 i386       1.4.0a-3.fc6     development       416 k
 fltk                    i386       1.1.8-0.3.r5750.fc7  development       424 k
 kde-settings            noarch     3.5-23.fc7       development        15 k
 kde-settings-kdm        noarch     3.5-23.fc7       development        15 k
 redhat-artwork-kde      i386       7.0.0-9.fc7      development       559 k

Transaction Summary
=============================================================================
Install      5 Package(s)         
Update       2 Package(s)         
Remove       0 Package(s)         

Total download size: 48 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications
for /usr/lib/vlc/codec/libdmo_plugin.so.
/etc/selinux/targeted/contexts/files/file_contexts: Multiple same specifications
for /usr/lib/vlc/codec/librealaudio_plugin.so.
Finished Transaction Test


Transaction Check Error:
  file /usr/share/config/kdm conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xaccess conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xsession conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xsetup conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/Xwilling conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/backgroundrc conflicts between attempted installs
of kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
  file /usr/share/config/kdm/kdmrc conflicts between attempted installs of
kdebase-3.5.6-10.fc7 and kde-settings-kdm-3.5-23.fc7
Comment 14 Rex Dieter 2007-05-21 07:36:59 EDT
note comment #5, fix was comitted/built Wed May 16, it's just (apparently)
taking ages to get this fixed build to rawhide/mirrors.
Comment 15 Kevin Kofler 2007-05-21 07:54:39 EDT
Your mirror is out of sync, download.fedora.redhat.com has 
kdebase-3.5.6-12.fc7.
Comment 16 Valent Turkovic 2007-05-21 14:41:47 EDT
Sorry for my lack of knowledge and experience with mirrors - but I thought that
all mirrors world-wide sync in matter or minutes and hours, and not days...

Is there a problem with the mirror system?
Comment 17 Kevin Kofler 2007-05-21 14:54:02 EDT
There were actually 3 steps needed to get the build pushed:
* tagging the build with f7-final
* getting a new Rawhide built from f7-final tagged builds
* getting the new Rawhide pushed out to the mirrors
all of which took a bit longer than usual, in part due to the recency of the 
merge. (Rawhide pushes didn't happen daily as normal, and mirrors had trouble 
getting all of former extras-development into their Rawhide mirror.)

But even in normal times, you should count with up to 1 day to get stuff into 
Rawhide once it's tagged f7-final (or once it's built when we're not in a 
freeze period) as Rawhide is only built once a day, and depending on your 
mirror, it may also take up to 1 day to get on the mirror.
Comment 18 Valent Turkovic 2007-05-21 16:31:35 EDT
I made yum update cleanly finally! I forced yum to clear all cache - twice! And
third time I guess it connected to an updated mirror and got updated kdebase and
updated without problems!

Note You need to log in before you can comment on or make changes to this bug.