Bug 240561 - x86_64 diskboot.img no longer works
Summary: x86_64 diskboot.img no longer works
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.5
Hardware: x86_64 Linux
high
high
Target Milestone: ---
: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 13:47 UTC by Richard Cunningham
Modified: 2018-10-19 23:25 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0816
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:36:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
experimental patch for mk-images.x86_64 (1.08 KB, patch)
2007-06-14 17:57 UTC, Bryn M. Reeves
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0816 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2007-11-14 18:43:57 UTC

Description Richard Cunningham 2007-05-18 13:47:49 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RedHat Enterprise 4 Update 5 WS x86_64 (regression - does not occur in earlier
versions)

How reproducible:
dd diskboot.img from the images directory on the first CD of RHEL4 U5 WS x86_64
to a usbdisk and try to boot from it

Steps to Reproduce:
1. dd if=diskboot.img of=/dev/sda
2. place usb key (sda) in USB drive of another machine
3. attempt to boot from it
  
Actual results:
SYSLINUX 2.11 2004-08-16  Copyright (C) 1994-2004 H. Peter Anvin
Could not find kernel image: linux
boot: _

Expected results:
Boot and show RedHat selection screen

Additional info:
If I mount the diskboot.img loopback I notice the following:

1. The image only has 2KB of free space (compared to 118K in Update 4)
2. The syslinux.cfg file is zero length
3. Fixing the syslinux.cfg by hand, causes the boot to continue slightly further
only to receive the following error:
Loading vmlinuz...
Loading initrd.img...
Ready.
Decompressing Linux...

ran out of input data

 -- System halted

Comment 2 RHEL Product and Program Management 2007-05-23 10:44:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 RHEL Product and Program Management 2007-05-23 10:46:19 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 9 Bryn M. Reeves 2007-06-14 17:46:30 UTC
Manually running mk-image for RHEL4.5/x86_64 seems to confirm this is a problem
with overrunning the hardcoded 6M image size:

cpio: ./isolinux/./syslinux-splash.png: No such file or directory
cpio: ./isolinux/./syslinux.cfg: No such file or directory
163840 pixels, 6000 bytes, (92.68% compression)
mv: cannot stat `./isolinux/syslinux.cfg': No such file or directory
mkdosfs 2.8 (28 Feb 2001)
cp: writing `./images/fobpath/vmlinuz': No space left on device
grep: write error: No space left on device

Comment 10 Bryn M. Reeves 2007-06-14 17:57:27 UTC
Created attachment 157025 [details]
experimental patch for mk-images.x86_64

Bump up the image size to 8M on x86_64. Boot tested & overcomes the initial
problem, i.e. the image is actually bootable. Also add some error checking to
make a failure copying files to the image fatal.

Comment 11 Bryn M. Reeves 2007-06-14 18:14:19 UTC
Manually hacking up the image to have the correct .buildstamp allows me to carry
out a RHEL4.5 x86_64 install via diskboot.img

Comment 13 Ram Rao 2007-07-17 18:57:30 UTC
Verified that replacing the rhel4u5 x86_64 supplied diskboot.img with the
patched diskboot.img:
http://people.redhat.com/breeves/images/diskboot.img-rhel4.5-x86_64-TEST
fixes my syslinux based installation procedure.

Thanks!


Comment 18 James Laska 2007-10-24 16:25:50 UTC
VERIFIED with a 64M USB MicroAdv QuickiDrive stick on a bensley x86_64 using the
diskboot.img from RHEL4-U6-re20071017.0/x86_64/WS.

1) $ dd if=diskboot.img of=/dev/sdb
2) reboot
3) Presented with graphical boot option screen


Comment 20 errata-xmlrpc 2007-11-15 16:36:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0816.html



Note You need to log in before you can comment on or make changes to this bug.