Bug 240570 - Can't mount GFS file system on AoE device
Can't mount GFS file system on AoE device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-18 10:43 EDT by Nate Straz
Modified: 2010-01-11 22:26 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0577
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 15:06:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the problem (567 bytes, patch)
2007-06-18 18:52 EDT, Robert Peterson
no flags Details | Diff

  None (edit)
Description Nate Straz 2007-05-18 10:43:13 EDT
Description of problem:

When trying to mount a GFS or GFS2 file system on an AoE device I get error 13
with the following backtrace in /var/log/messages.

May 18 09:31:01 tank-05 kernel: kobject_add failed for etherd/e1.1p1 (-13)
May 18 09:31:01 tank-05 kernel:  [<c04dc184>] kobject_add+0x147/0x16d
May 18 09:31:01 tank-05 kernel:  [<c04dc290>] kobject_register+0x19/0x30
May 18 09:31:01 tank-05 kernel:  [<f8d419ca>] fill_super+0x3df/0x5c9 [gfs]
May 18 09:31:01 tank-05 kernel:  [<c04708a2>] get_sb_bdev+0xc6/0x110
May 18 09:31:01 tank-05 kernel:  [<c0453eda>] __alloc_pages+0x57/0x27e
May 18 09:31:01 tank-05 kernel:  [<f8d40d15>] gfs_get_sb+0x12/0x16 [gfs]
May 18 09:31:01 tank-05 kernel:  [<f8d415eb>] fill_super+0x0/0x5c9 [gfs]
May 18 09:31:01 tank-05 kernel:  [<c0470367>] vfs_kern_mount+0x7d/0xf2
May 18 09:31:01 tank-05 kernel:  [<c047040e>] do_kern_mount+0x25/0x36
May 18 09:31:01 tank-05 kernel:  [<c0482e60>] do_mount+0x5d6/0x646
May 18 09:31:01 tank-05 kernel:  [<c044f818>] find_get_pages_tag+0x30/0x6e
May 18 09:31:01 tank-05 kernel:  [<c0455833>] pagevec_lookup_tag+0x1b/0x22
May 18 09:31:01 tank-05 kernel:  [<c0488e04>] mpage_writepages+0x2a5/0x304
May 18 09:31:01 tank-05 kernel:  [<f88ee5bf>] e1000_xmit_frame+0x94b/0x97c [e1000]
May 18 09:31:01 tank-05 kernel:  [<c0453c09>] get_page_from_freelist+0x96/0x310
May 18 09:31:01 tank-05 kernel:  [<c0453e19>] get_page_from_freelist+0x2a6/0x310
May 18 09:31:01 tank-05 kernel:  [<c0453c09>] get_page_from_freelist+0x96/0x310
May 18 09:31:01 tank-05 kernel:  [<c0481df0>] copy_mount_options+0xa5/0x109
May 18 09:31:01 tank-05 kernel:  [<c0482f3d>] sys_mount+0x6d/0xa5
May 18 09:31:01 tank-05 kernel:  [<c0403eff>] syscall_call+0x7/0xb


Version-Release number of selected component (if applicable):
kernel-2.6.18-8.el5
kmod-gfs-0.1.16-5.2.6.18_8.el5


How reproducible:
100%

Steps to Reproduce:
1. mount -t gfs /dev/etherd/e1.1p1 /mnt

Actual results:
See above

Expected results:
The file system should mount.

Additional info:
Comment 1 Nate Straz 2007-05-18 16:20:54 EDT
I was able to mount a GFS file system if I use LVM2 between the AoE device and
the file system.
Comment 2 David Teigland 2007-05-18 16:48:46 EDT
The problem is that the aoe driver puts a "/" in the name it assigns
to its gendisk disk_name.  GFS takes this gendisk name as the fs name
when no fs name was provided by mkfs (nolock doesn't require an fs name).
And gfs then uses this fs name as a sysfs directory name which fails
because "/" is an invalid character for a file name.

A quick work-around is to provide a table name (anything) when running
gfs_mkfs -p lock_nolock.

Real fix is for gfs to sanitize the fs name if it takes it from the vfs
(after table = sdp->sd_vfs->s_id in init_names()).
Comment 3 Nate Straz 2007-05-18 18:35:12 EDT
Should sdp->sd_vfs->s_id be a valid filename?  Perhaps the AoE driver storing an
invalid s_id?  All of the files in /sys/block look like "etherd!e1.1"
Comment 4 Robert Peterson 2007-06-18 18:52:50 EDT
Created attachment 157338 [details]
patch to fix the problem

Patch tested on trin-10 by editing the lock table.
This is ready to ship; I just need some ack flags now.
Comment 5 RHEL Product and Program Management 2007-06-18 18:53:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Robert Peterson 2007-06-19 10:26:12 EDT
Fix committed to HEAD and RHEL5 branches of CVS.  Changing status to
modified.
Comment 9 errata-xmlrpc 2007-11-07 15:06:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0577.html
Comment 10 Nate Straz 2007-12-19 15:06:40 EST
Moving all closed bugs to gfs-kmod to match the rpm name.  GFS-kernel will be
removed.

Note You need to log in before you can comment on or make changes to this bug.