Bug 240579 - malloc memory corruption attempting to run emacs
Summary: malloc memory corruption attempting to run emacs
Status: CLOSED DUPLICATE of bug 239344
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 15:25 UTC by Geoff Gustafson
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 15:34:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Geoff Gustafson 2007-05-18 15:25:42 UTC
Description of problem:
I installed FC7 test4 yesterday and emacs worked fine. Then I did a yum update
and now when I run emacs I get:

*** glibc detected *** emacs: malloc(): memory corruption: 0x0000000002897380 ***
======= Backtrace: =========
/lib64/libc.so.6[0x2aaaac4a9d8c]
/lib64/libc.so.6(__libc_malloc+0x7d)[0x2aaaac4ab69d]
emacs[0x50ac5c]
/lib64/libc.so.6[0x2aaaac460ebd]
/lib64/libc.so.6[0x2aaaac46174a]
/lib64/libc.so.6[0x2aaaac46088d]
/lib64/libc.so.6(setlocale+0x15e)[0x2aaaac46026e]
emacs[0x4b285f]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x2aaaac456aa4]
emacs[0x40d9e9]

This occurs with glibc-2.6-1. If I revert to glibc-2.5.90-21 emacs runs okay again.

Version-Release number of selected component (if applicable):
glibc-2.6-1

How reproducible:
Only tried on this one box, Intel D3C8A06 SDV. But I reverted only glibc and it
was fixed. Then I upgraded to 2.6-1 again, problem came back. Reverted again and
it was fixed again.

Comment 1 Will Woods 2007-05-18 15:34:06 UTC

*** This bug has been marked as a duplicate of 239344 ***


Note You need to log in before you can comment on or make changes to this bug.