Bug 240595 - Repomd can break with custom packages in proxy channels
Repomd can break with custom packages in proxy channels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Mike Orazi
:
: 240021 (view as bug list)
Depends On: 247327
Blocks: 239809
  Show dependency treegraph
 
Reported: 2007-05-18 13:31 EDT by James Bowes
Modified: 2013-01-10 04:53 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.0.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-25 11:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Máirín Duffy 2007-05-23 15:46:29 EDT
Attempts to install packages from custom RHEL 5-based channels with packages
stored on an RHN Proxy result in an error message that includes the following:

"Error: Cannot open/read repomd.xml file for repository"

From jbowes: Generating the repomd files for rhel 5 reads package path from the
database to determine the rpm's file name. this value is empty for custom
channels with packages stored by a proxy. In this case, repomd generation should
fall back to what the proxy does, and build a best-guess for the file name based
on package
NEVRA.
Comment 4 Clifford Perry 2007-05-25 15:46:34 EDT
*** Bug 240021 has been marked as a duplicate of this bug. ***
Comment 8 RHEL Product and Program Management 2007-06-06 15:07:40 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 James Bowes 2007-07-25 11:15:32 EDT
rhn502 released.

Note You need to log in before you can comment on or make changes to this bug.