Bug 240598 - net-snmp ssCpuRawIdle counter gets stuck at 2^32-1
Summary: net-snmp ssCpuRawIdle counter gets stuck at 2^32-1
Status: CLOSED DUPLICATE of bug 223775
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ucd-snmp   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-18 17:58 UTC by Joel Matuseski
Modified: 2015-03-05 01:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 21:32:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joel Matuseski 2007-05-18 17:58:26 UTC
Description of problem:


Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.10

How reproducible:
100%

Steps to Reproduce:
1. Wait until UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295
2.
3.
  
Actual results:
Counter gets stuck at 4294967295

Expected results:
Counter should wrap over to zero

Additional info:
This is handled by net-snmp's offical patch located at
http://net-snmp.cvs.sourceforge.net/net-snmp/net-snmp/agent/mibgroup/ucd-snmp/vmstat.c?r1=5.7&r2=5.8

I checked the source RPM tarball and patches for the version listed and vmstat.c
shows the pre-patched version at net-snmp's sourceforge link above. 

The counter sticking throws off our monitoring and instrumentation for the
servers. A reboot is the only current fix.

Comment 1 Bryan Mason 2007-07-24 21:32:08 UTC

*** This bug has been marked as a duplicate of 223775 ***


Note You need to log in before you can comment on or make changes to this bug.