Bug 240622 - x86_64: OO.org (scalc/writer/etc) crashing during startup.
x86_64: OO.org (scalc/writer/etc) crashing during startup.
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2007-05-18 18:13 EDT by Gilboa Davara
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-20 05:16:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdb log (11.38 KB, text/plain)
2007-05-18 18:13 EDT, Gilboa Davara
no flags Details
pre-crash gdb log. (osl_loadModule -> osl_psz_loadModule. ) (5.34 KB, text/plain)
2007-05-18 18:29 EDT, Gilboa Davara
no flags Details

  None (edit)
Description Gilboa Davara 2007-05-18 18:13:33 EDT
Description of problem:
No idea why/how it began.
Seems to have started two days.
Tried deleting $HOME/.openoffice but it didn't change anything.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep openoffice | sort

How reproducible:

Steps to Reproduce:
1. Start OO.
2. Crash.

Additional info:
Related to #226942?
Comment 1 Gilboa Davara 2007-05-18 18:13:33 EDT
Created attachment 155033 [details]
gdb log
Comment 2 Gilboa Davara 2007-05-18 18:29:41 EDT
Created attachment 155034 [details]
pre-crash gdb log. (osl_loadModule -> osl_psz_loadModule. )

" #13 0x00000033c4e2ec04 in osl_psz_loadModule (pszModuleName=0x1 <Address 0x1
out of bounds>,
       nRtldMode=<value optimized out>) at module.c:136"

Without looking into the code, I can't really understand what's going on... but
something goes horribly wrong between osl_loadModule and osl_psz_loadModule. 

Check the gdb session log below.

- Gilboa
Comment 3 Caolan McNamara 2007-05-19 07:36:02 EDT
hmm, most strange, simply looks like it is blowing up on dlopening
/usr/lib64/openoffice.org2.0/program/typemgr.uno.so . Perhaps make a backup of
that library and extract that lib from the original rpms with cd /tmp/foome &&
rpm2cpio *core.rpm|cpio -ivd and copy it into
/usr/lib64/openoffice.org2.0/program and see if that makes a difference.
Comment 4 Gilboa Davara 2007-05-19 09:04:17 EDT
I remove the offending openoffice package (openoffice.org-core) and reinstalled
it and it seems to be working just fine now.

Any idea what went wrong?

- Gilboa
Comment 5 Caolan McNamara 2007-05-19 13:21:52 EDT
perhaps it was prelink that triggered the problem, it rewrites some libraries.
Maybe a manual /usr/sbin/prelink -av -mR to force prelink to happen on the
freshly installed .sos might recreate the state OOo was in before the reinstall
of the libraries ? If it breaks right after the prelink then this might be the
trigger of the problem, otherwise I have no idea.
Comment 6 Gilboa Davara 2007-05-20 05:16:11 EDT
I re-tried running prelink but didn't see anything blow up.
The machine is being used for driver development - it is entirely possible that
it crashed while prelink was running, breaking OO.

Anyways, thanks for help.

- Gilboa
Comment 7 Gilboa Davara 2007-05-20 05:16:48 EDT
... Should I close the BZ#?

Note You need to log in before you can comment on or make changes to this bug.