Bug 240673 - amarok should not depend on ruby
Summary: amarok should not depend on ruby
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-19 22:20 UTC by Bernie Innocenti
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 06:19:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernie Innocenti 2007-05-19 22:20:25 UTC
Now that ruby-libs has been split out of ruby,
the explicit dependencies should go away.

There are also a number of annoying dependencies such
as mysql, jack, etc.  Isn't it possible to drop them
somehow?  (probably requires work upstream)

Comment 1 Aurelien Bompard 2007-05-21 06:19:39 UTC
The dependence on ruby is there because of the lyrics script (which is run by
default)
The dependency on MySQL is there because Amarok can store its music collection
in MySQL (and PostgreSQL). To my knowledge there is no way to make it a plugin
at the moment. Someone already posted an RFE upstream :
http://bugs.kde.org/show_bug.cgi?id=102318


Note You need to log in before you can comment on or make changes to this bug.