Bug 240674 - Redraws and scrolling slow with Window Maker / Fedora Core 6
Redraws and scrolling slow with Window Maker / Fedora Core 6
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: WindowMaker (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-19 19:10 EDT by Martin Burchell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 12:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Burchell 2007-05-19 19:10:42 EDT
Description of problem:
Since I upgraded from Fedora Core 5 to Fedora Core 6 I have noticed that windows
are redrawn more slowly and scrolling is more sluggish.

When new windows are opened the redraws are often visible and sometimes
momentarily contain garbage before being overwritten with the correct data.

When I open certain pages in Firefox and scroll down with the cursor keys, it
takes much longer for the page to scroll to the bottom than in KDE.  For example:
http://www.linuxemporium.co.uk/products/keyboards/
KDE: 6s
Window Maker: 35s

http://www.ccohs.ca/oshanswers/ergonomics/office/mouse/mouse_problems.html
KDE: 4s
Window Maker: 22s

This may be improved by restarting the window manager - I need to do some more
investigation.

Also sometimes artifacts/artefacts of the Window Maker application menus are
left behind instead of the menu disappearing altogether.  This may well be
unrelated to the other problems.

I'm not convinced that Window Maker is to blame but I don't have much to go on.

Version-Release number of selected component (if applicable):
WindowMaker-0.92.0-10.fc6


How reproducible:
Every time

Steps to Reproduce:
1. Start X with Window Maker as window manager
2. Open applications such as Thunderbird and Firefox
3. Observe window redraws and scrolling
  
Actual results:
Windows should be redrawn quickly, scrolling should be fast and smooth 

Expected results:
Windows are drawn slowly, often filling with garbage before the correct data,
scrolling is slow and jerky 

Additional info:
Comment 1 Andreas Bierfert 2007-05-21 05:08:56 EDT
Hm, I am using wmaker every day and I do not see this behavior not on nvidia
cards not on ati cards... Seems to me this is a problem with the graphics driver
but it sounds strange that it would work in kde. Please investigate a bit more
and get back to me.
Comment 2 Martin Burchell 2007-05-23 18:19:45 EDT
That would confirm my suspicion that Window Maker isn't responsible, especially
as the software is largely unchanged between fc5 and fc6.

I've now tried xfce and twm in addition to KDE and the window redraws are all
fine in those environments.

As regards graphics drivers, there seems to be a unique problem with mine.  That
started appearing when I "upgraded" from FC4 to FC5 and is still present in FC6.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=204789

However, I don't think this bug is related.

Anyway I'll try building my own Window Maker rpm from source and see if I can
get any useful debugging out of it.

BTW I seem to have muddled up the Actual and Expected results in my comments
above but hopefully that's obvious.
Comment 3 Andreas Bierfert 2007-05-24 02:16:37 EDT
You can also grep the debuginfo rpm and try to get some debugging out of the
'official' package.

I am sorry that I cannot really help you at the moment. If you have any clues I
can follow I'd be glad to help.
Comment 4 Martin Burchell 2007-06-17 11:50:26 EDT
I've been making some changes to my xorg.conf in order to resolve other issues
and this seems to be down to the setting of DefaultDepth in the "Screen"
section. In Fedora Core 5 I had this set to 16 and kept this when upgrading to
Fedora Core 6.  If I change the depth to 24, performance is a lot better and I
don't see the artefacts I mentioned.

As a test I timed how long it took to do an ls -l of the /usr/bin directory
(2905 lines) within a GNU Screen session under different environments for the
two colour depths.  The results are as follows:

depth 16
--------
Window Maker 54s
xfwm4 3s
twm 2s 
KDE 1s

depth 24
--------
Window Maker 3s
xfwm4 3s
twm 3s
KDE 1s

The error is probably about +/- 1s as I was timing not particularly
scientifically with a watch.
As you can see, Window Maker is taking considerably longer at a colour depth of 16.

I'm happy setting the depth to 24 so this is no longer really an important issue
but I'm still curious as to why this is happening and why the performance
deteriorated following the upgrade to FC6.

It may of course have something to do with my graphics card/monitor combination
(Intel 810 / Samsung SyncMaster 171P).
Comment 5 Andreas Bierfert 2007-06-17 12:09:10 EDT
Thanks for reporting back. I just tested this with my laptop (ati, default x
radeon driver) and it worked without problems. The ls -ls /usr/bin/ took 4.218
seconds. In case you ever need it take a look at the 'time' command. It can
measure running time of programs rather easy.

I have no clue why this is happening on your computer but I guess it maybe is
some strange combination of i810 and WindowMaker. I am closing this now as
cantfix. Feel free to let me know if you find out more. If I find it more I will
reopen as well.

Note You need to log in before you can comment on or make changes to this bug.