Bug 240678 - [iwlwifi] 99% cpu with ksoftirqd/0
Summary: [iwlwifi] 99% cpu with ksoftirqd/0
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: alpha
OS: Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-20 00:59 UTC by kaustubh
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 14:56:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kaustubh 2007-05-20 00:59:42 UTC
Description of problem:
Fedora release 6.93 (Rawhide)

Issue is with the kernel versions above 2.6.21-1.3116. 

ksoftirqd/0 will use 99% of system resources, i have gone through few posts and
found that it may be related with iwlwifi, I am using D620 dell laptop
== 
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network
Connection (rev 02)
==

Currently i am not using wifi, a normal cable is attached but still the cup
consumption is high. I tried to remove it module which took 100% of cpu and than
locked up the box.

I have gone through many posts regarding this. I know that there are some issue
with this card, which are fixed with 2.6.21-1.3167 but those are related with
connectivity and not the cpu consumption( average load increase due to this).
There are many newer kernel available i due to load issue i am not able to use
those. Currently using 2.6.21-1.3116.

Any plans on this ?

Comment 1 Dave Jones 2007-10-11 06:39:05 UTC
still a problem on the current kernels ?

Comment 2 kaustubh 2007-10-12 14:49:57 UTC
Nop Dave, things are working fine now with the latest kernel ... 


Note You need to log in before you can comment on or make changes to this bug.