This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 240688 - power button (set to "ask" in gnome-power-manager) doesn't ask, instead locks X
power button (set to "ask" in gnome-power-manager) doesn't ask, instead locks X
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-20 08:13 EDT by Leszek Matok
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-29 15:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leszek Matok 2007-05-20 08:13:52 EDT
For few days now, pressing the power button of my Thinkpad T30, instead of
asking whether I want to shutdown or restart the machine, gradually darkens the
screen a little, then stops darkening and hangs in this state forever. No window
is shown, no keys work, no visible (behind the "dark glass", but visible)
windows show any updates. I can move the mouse cursor, though.

In this state, all I can do is kill X using alt-ctrl-backspace. I can also
switch to tty1 and kill gnome-session, or switch back to vt 7, where I see some
screen corruption at the top, which doesn't refresh to proper screen content.

On tty1 I checked if some program is looping taking whole CPU, but nothing like
that takes place.

I also checked for some messages in Xorg.0.log (suspecting "radeon" driver bug),
but it doesn't change between before and after pushing the button.

If I set the button function to suspend, it suspends without problem. Only
"asking" locks my session for good.

Everything used to work in FC7t4, but stopped with some of this week's updates
(which included gnome-power-manager, gnome-session and xorg-x11-server-Xorg,
every one of them is suspected). Now it's reproducible every time, so I can
provide every information you need.
Comment 1 Leszek Matok 2007-05-27 12:12:44 EDT
I've found an hour to test it and I confirm that the problem is in gnome-session.

In gnome-session-2.18.0-5.fc7 it works.

In gnome-session-2.18.0-7.fc7 it doesn't work.

Can't anyone reproduce it?
Comment 2 Ray Strode [halfline] 2007-05-29 15:06:49 EDT
ah this should be fixed in 2.18.0-8.fc7

Note You need to log in before you can comment on or make changes to this bug.