Bug 240733 - Boot traceback "Bad page state in process 'Xorg'" after starting gpm (possibly hardware problem)
Boot traceback "Bad page state in process 'Xorg'" after starting gpm (possibl...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 427887
  Show dependency treegraph
 
Reported: 2007-05-21 06:45 EDT by Pekka Savola
Modified: 2008-01-21 02:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 02:07:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2007-05-21 06:45:25 EDT
I saw the following appear in messages log when booting up an IBM Thinkpad X30
with 2.6.20-1.2948.fc6.

I wonder if this is gpm vs Xorg's mouse handling related or whether the messages
coming up after gpm is just a coincidence.

May 21 12:57:46 lapps gpm[2443]: *** info [startup.c(95)]: 
May 21 12:57:46 lapps gpm[2443]: Started gpm successfully. Entered daemon mode.
May 21 12:57:46 lapps gpm[2443]: *** info [mice.c(1766)]: 
May 21 12:57:46 lapps gpm[2443]: imps2: Auto-detected intellimouse PS/2
May 21 12:57:49 lapps kernel: Bad page state in process 'Xorg'
May 21 12:57:49 lapps kernel: page:c112b150 flags:0x40000000 mapping:01000000
mapcount:0 count:0 (Not tainted)
May 21 12:57:49 lapps kernel: Trying to fix it up, but a reboot is needed
May 21 12:57:49 lapps kernel: Backtrace:
May 21 12:57:49 lapps kernel:  [<c0459e7f>] bad_page+0x6a/0x96
May 21 12:57:49 lapps kernel:  [<c045a6be>] get_page_from_freelist+0x1e1/0x2a7
May 21 12:57:49 lapps kernel:  [<c045a7ec>] __alloc_pages+0x68/0x2aa
May 21 12:57:49 lapps kernel:  [<c04669bf>] anon_vma_prepare+0x20/0xb8
May 21 12:57:49 lapps kernel:  [<c045c4ca>] __pagevec_lru_add_active+0x80/0x8b
May 21 12:57:49 lapps kernel:  [<c046148f>] __handle_mm_fault+0x3e2/0x8ba
May 21 12:57:49 lapps kernel:  [<c0463fbc>] vma_link+0x54/0xc7
May 21 12:57:49 lapps kernel:  [<c0464e28>] do_mmap_pgoff+0x58a/0x6ee
May 21 12:57:49 lapps kernel:  [<c0621d92>] do_page_fault+0x216/0x4da
May 21 12:57:49 lapps kernel:  [<c0621b7c>] do_page_fault+0x0/0x4da
May 21 12:57:49 lapps kernel:  [<c06207e4>] error_code+0x7c/0x84
May 21 12:57:49 lapps kernel:  [<c0620033>] rt_mutex_slowlock+0x399/0x44f
May 21 12:57:49 lapps kernel:  =======================
May 21 12:57:50 lapps avahi-daemon[2530]: Found user 'avahi' (UID 70) and group
'avahi' (GID 70).
....

a little later later also in messages:

May 21 13:05:46 lapps dhclient: bound to 172.22.249.245 -- renewal in 50 seconds.
May 21 13:06:29 lapps gpm[2443]: *** info [mice.c(1766)]: 
May 21 13:06:29 lapps gpm[2443]: imps2: Auto-detected intellimouse PS/2
May 21 13:06:29 lapps kernel: BUG: sleeping function called from invalid context
at include/asm/uaccess.h:445
May 21 13:06:29 lapps kernel: in_atomic():0, irqs_disabled():1
May 21 13:06:29 lapps kernel:  [<c0408ee9>] save_i387+0x178/0x2ac
May 21 13:06:29 lapps kernel:  [<c040324b>] setup_sigcontext+0x10b/0x18b
May 21 13:06:29 lapps kernel:  [<c0403977>] do_notify_resume+0x40b/0x65b
May 21 13:06:29 lapps kernel:  [<c043abff>] do_adjtimex+0x466/0x47c
May 21 13:06:29 lapps kernel:  [<c061fb28>] do_nanosleep+0x42/0x66
May 21 13:06:29 lapps kernel:  [<c044ddc7>] audit_syscall_exit+0x294/0x2b0
May 21 13:06:29 lapps kernel:  [<c047dcbf>] sys_select+0xd6/0x187
May 21 13:06:29 lapps kernel:  [<c0403ff2>] work_notifysig+0x13/0x19
May 21 13:06:29 lapps kernel:  =======================


finally, it crashed hard with the following on the console (parts of it
missing, copied on paper by hand):

.... (screen scrolled past) ...
handle_IRQ_event+0x1a/0x3f
handle_level_irq+0x43/0xdf
handle_level_irq+0x0/0xdf
do_IRQ+0xb5/0x28
common_interrupt+0x23/0x28
keyctl_keyring_unlink+0x64/0x7a
mls_context_invalid+0xf/0x18a
policydb_context_isvalid  [didn't other to write the offsets from here on]
security_compute_sid
inode_has_perm
security_transition_sid
selinux_bprm_set_security
sched_exec
prepare_binprm
do_execve
sys_execve
syscall_call
rt_mutex_slowlock+0x399/0x44f

..
EIP: [<0xc0ffab13>] dma_pool_free+0x33/0x138 SS: ESP 0068:x07abf10
Comment 1 Chuck Ebbert 2007-05-21 17:01:51 EDT
Does this problem happen consistently?
It almost looks like some kind of hardware problem.
Comment 2 Pekka Savola 2007-05-28 01:19:23 EDT
I've seen this only once.

Hardware problem is possible.  The laptop's PCMCIA interface is already broken
in some weird way, so it's possible something else could be broken as well. 
Typically the laptop works fine though.
Comment 3 Jon Stanley 2008-01-07 20:55:41 EST
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 4 Pekka Savola 2008-01-21 02:07:28 EST
I've no longer seen this on FC8, so closing.

Note You need to log in before you can comment on or make changes to this bug.