Bug 240740 - GKsu instead consolehelper or improvement
GKsu instead consolehelper or improvement
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-21 07:36 EDT by Jakub 'Livio' Rusinek
Modified: 2014-03-16 23:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 12:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub 'Livio' Rusinek 2007-05-21 07:36:36 EDT
Console helper, when asks for password doesn't make background grayscale and
it's window like any other - with border. This is bad behavior.

We could use also gksu instead.
Comment 1 Bill Nottingham 2007-05-21 07:44:43 EDT
How is it bad behavior? Note that gksu has some seriously awful code in it - see
http://www.linuxpowertop.org/known.php.
Comment 3 Bug Zapper 2008-04-03 20:48:50 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Jon Stanley 2008-04-05 12:21:06 EDT
Umm, some comments Jakub?  Bill has already said that he's unlikely to switch,
and has requested information on how this is bad behavior.
Comment 5 Matthias Clasen 2008-04-05 13:25:01 EDT
A switch to gksu seems exceedingly unlikely, now that we have PolicyKit.
Comment 6 Jakub 'Livio' Rusinek 2008-04-05 15:17:53 EDT
I have idea. This bug seems inactual, however if I "move" bug upstream, to
PolicyKit, it might be available for all.

system-config tools will use PolicyKit?
Comment 7 Bill Nottingham 2008-04-07 12:01:34 EDT
Eventually.
Comment 8 Jakub 'Livio' Rusinek 2008-04-07 12:19:04 EDT
Why? Isn't it good idea to keep whole desktop consistent?
Comment 9 Jesse Keating 2008-04-07 12:25:21 EDT
(In reply to comment #8)
> Why? Isn't it good idea to keep whole desktop consistent?

Because it takes time to port apps.  Things can't be done instantly.

Note You need to log in before you can comment on or make changes to this bug.