Bug 240742 - clearpart -all also removes partitions on external devices
clearpart -all also removes partitions on external devices
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-21 07:51 EDT by David Swegen
Modified: 2016-02-17 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 10:31:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Swegen 2007-05-21 07:51:36 EDT
Description of problem:

While installing RHEL5 using a kickstart file that contained a 'clearpart --all'
entry, I was somewhat dismayed to discover that the external USB disk I had
forgotten to disconnect.

Now technically it doing the right thing - it is doing what I actually asked it
to do. However, I feel that blowing away external devices is somewhat unexpected
behaviour - it feels decidedly unsafe.

How reproducible:

Always


Steps to Reproduce:
1. Attach a USB disk (might also work with other external devices such as SANs
and USB keys) to machine
2. Install using a kickstart file that contains the line 'clearpart --all'

Actual results:

Wave byebye to all data on external drive

Expected results:

As it is an external drive I would expect it to, by default, not touch it. An
explicit flag --external or somesuch would be nice.
Additional info:
Comment 1 Jeremy Katz 2007-05-21 10:31:53 EDT
We also will install to external drives.  

If you don't want external drives to be considered at all, add 'nousbstorage' to
your boot command line and we won't ever load the module.  You can also specify
specific disks to clear with --drives= on your clearpart line or add drives to
be explicitly ignored with ignoredrive.
Comment 2 David Swegen 2007-05-21 11:07:41 EDT
Agreed it is not a bug, and I am aware of the various options that can be passed
to the kernel and installer. However, IMHO the default should be the other way
round, as it is far more likely that somebody will have external storage
connected that they don't wish to install to/blow away: Defaulting to an
accidental data loss situation just seems... wrong.

But maybe that's just me :)

Note You need to log in before you can comment on or make changes to this bug.