Bug 240746 - Virt-manager says not enough space to install
Virt-manager says not enough space to install
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Xen Maintainance List
Depends On:
  Show dependency treegraph
Reported: 2007-05-21 08:54 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-21 09:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xend.log (16.26 KB, text/plain)
2007-05-21 08:54 EDT, IBM Bug Proxy
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 26730 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-05-21 08:54:24 EDT
LTC Owner is: suzukikp@in.ibm.com
LTC Originator is: plars@us.ibm.com

Using virt-manager to create a xen guest, I specified simple file as the storage
target.  I gave it a filename and told it to give it 3500 MB for the size (yes,
it was a new file).

At this point, anaconda starts and I go through the initial steps.  
I selected Software Development in addition to the "office and productivity"
category from the package selection screen.

After the dependancy check, I get the following error:

Your selected packages require 2183 MB of free space for installation, but you
do not have enough available.  You can change your selections or reboot. 

Going back and selecting a more minimal set of packages to install doesn't help
either, though even with the 2183 MB required, the 3500 I allocated for it
should be plenty.

Here are the relevant package versions:


Created an attachment (id=19559)

I'm attaching xend.log, xend-debug.log and xen-hotplug.log did not have

This is looking like some miscalculation in virt-manager. I'm guessing Rik et.
al. would like to see it...

Well, what used to be FC6 should now be in Beta 2, right?  Should this be
retested on Beta2?

I verified with the RHEL5-Beta2 version(2.6.18-1.2747.el5xen), and what I could
observe from this is, 
After we select a file of size 3500 MB for installation, the default
partition-selection will create a logical volumes logvol00 and logvol01.
Here the logvol00 corresponds to "/"  having size 1696 MB and the logvol01
corresponds to the "swap" of size 1664 MB. And also we have /boot device of 100 MB.

    And the RHEL is going to install on /dev/volgroup00/logvol00, which has
space of 1696 MB, and so the installation greater than this size won't continue

Since Paul hasn't mentioned anything about the disk-space(filespace) allocation,
in particular Swap space, it maybe the reason of getting the earlier error.

Also I tried with my custom-partitioned disk-layout(file-layout), without having
any swapspace allocated on a file-size of 3.5 GB, and I was able to install
without any problems.

So you can close the bug.

So the problem is solved by custom partitioning (or rather, closely inspecting
the defaults.)  For the casual user (if such exists in Xen :) )  would it be
apparent that custom partitioning is needed from the beginning?  Seems to me
there would still be a bug (albeit, a lower priority one) if it takes an hour
and a half, for instance, to learn you need a bigger partition.

I think this is a problem with the generic install scripts in computing the
sizes for the automatic partitioning.
Comment 1 IBM Bug Proxy 2007-05-21 08:54:25 EDT
Created attachment 155091 [details]
Comment 2 IBM Bug Proxy 2007-05-21 08:57:58 EDT
LTC Attachment ID: 19559
Comment 3 Daniel Berrange 2007-05-21 09:05:23 EDT
The guest has 2 GB of RAM, and anaconda will try to allocate upto 2x RAM for
swap (but IIRC limited to 2 GB, or 1/2 of disk), hence you got 1.7 GB allocated
to swap. So you're only left with another 1.7 GB for /, into which you're trying
to install 2.1 GB of software. If you have so much RAM in your guest, you need
far more disk space to account for swap usage, or you need to manually
partition. Either way, this is not virt-manager's problem, or Xen specific.
Simply trying to install too much software in too litle disk space.

The final question about anaconda taking too long to tell you about not having
enough disk space is also not a bug in virt-manager or anything Xen specific.
File a bug against anaconda if it is too slow.
Comment 4 IBM Bug Proxy 2007-05-21 14:10:33 EDT

           What    |Removed                     |Added
             Status|ASSIGNED                    |REJECTED
         Resolution|                            |NOTABUG

------- Additional Comments From suzukikp@in.ibm.com (prefers email at suzuki@in.ibm.com)  2007-05-21 14:03 EDT -------
Closing the bug at IBM side too.



Note You need to log in before you can comment on or make changes to this bug.