Bug 240760 - yaboot tries to boot from partition -1 (multiple SAS disks)
Summary: yaboot tries to boot from partition -1 (multiple SAS disks)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot   
(Show other bugs)
Version: rawhide
Hardware: ppc64 Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 14:28 UTC by Jochen Roth
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 08:07:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jochen Roth 2007-05-21 14:28:02 UTC
Description of problem:
The installation of Fedora 7 test4 on multiple multipath SAS disks works fine. 

yaboot tries to boot the installation but fails with the following error message:
---------------
0 > boot disk1
Trying to load:  from: /axon@10000000000/plb5/plb4/pcix@4000004600000000/scsi@
2/disk@0,13,f ...   Successfully loaded

/axon@10000000000/plb5/plb4/pcix@4000004600000000/scsi@2/disk@0,13,f:-1,/etc/y
aboot.conf: Unknown or corrupt filesystem
Can't open config file
Welcome to yaboot version 1.3.13 (Red Hat 1.3.13-4.fc7)
Enter "help" to get some basic usage information
boot:
boot: linux
Please wait, loading kernel...
linux:-1,/vmlinux: Unable to open file, Invalid device
boot:
----------------

The default partitioning layout for two disks looks like this: 

LVM Group 00 
   -> LogVol01     swap   2GB
   -> SWAP      /  ext3 206GB

mapper/mpath0: 
   -> ext3    /boot   100MB
   -> LVMGroup0     130GB

mapper/mpath1: 
   -> PPC PReP Boot    8MB
   -> LVMGroup0      70GB

Version-Release number of selected component (if applicable):
fedora 7 test4 installation DVD

How reproducible:
always 


Steps to Reproduce:
1.Install fedora 7 test4 on 2 SAS disks 
2.Boot installation

Additional info:

This happens on a Cell based system. 

Changing the default partitioning layout to the following solves the problem. 
Note that the PReP and the /boot partition are on the same disk.

LVM Group 00
   -> LogVol01      swap   2GB
   -> LogVol00   /  ext3 206GB

mapper/mpath0
   -> PPC PReP Boot        8MB
   -> /boot       ext3   102MB
   -> VolGroup00         138GB

mapper/mpath1
   -> VolGroup00          68GB

Comment 1 Paul Nasrat 2007-05-21 14:42:04 UTC
Please attach a compressed tarball of /proc/device-tree

Please also test yaboot 1.3.14rc2 available from yaboot.ozlabs.org built with
DEBUG=1

Comment 2 Jochen Roth 2007-05-23 08:07:27 UTC
Thanks for the quick reply. 
I created a new installer with the latest yaboot and compiled with DEBUG=1. 

But mysteriously the default partitioning layout is now always correct. 

I suggest to close this bug as unreproducible as the default partitioning layout
is correct now. 

But thanks anyway for your help. 


Note You need to log in before you can comment on or make changes to this bug.