Bug 240773 - xrandr mode changes sometimes bring gnome session down
Summary: xrandr mode changes sometimes bring gnome session down
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 15:57 UTC by Osma Ahvenlampi
Modified: 2018-04-11 09:15 UTC (History)
3 users (show)

Fixed In Version: gtk2-2.10.12-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-23 14:07:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy's stracktrace of a crashing app (10.52 KB, text/plain)
2007-05-21 21:16 UTC, Osma Ahvenlampi
no flags Details

Description Osma Ahvenlampi 2007-05-21 15:57:12 UTC
I have a laptop which I connect to an external display, and the new xrandr
version in FC7 is a major change for me, since it allows me to switch from
built-in screen only (or screen cloning) to dual-screen mode on the fly.

However, this doesn't always work - maybe half the times I make an xrandr
resolution/display mode switch, it goes bad. There seems to be three different
ways for it to break, and I'm unsure how to debug them, or whether they're
different enough to warrant separate tickets.

1. Programs in the session die - most frequently gnome-power-manager, oftentimes
many others, popping up the bug-buddy dialog. Perhaps due to a dbus signal they
can't deal with? I tried attaching dbus-monitor and couldn't see any signals
being emitted when I change the mode, though, so perhaps it's something else.

2. The entire session (or xorg) dies, throwing me back to the gdm screen. No
clue in the log files.

3. Xorg completely hangs, forcing me to kill power. Might be upstream
https://bugs.freedesktop.org/show_bug.cgi?id=10664

Comment 1 Ray Strode [halfline] 2007-05-21 17:38:34 UTC
Hi,

gnome-desktop isn't the right component for this (it's just a tiny package with
a bad name).

since 2 and 3 seem to suggest some sort of X problem, i'm going to punt to
xorg-x11-server.  

We may need to open up a gnome-power-manager bug if there isn't the same root
cause between all 3.

Comment 2 Osma Ahvenlampi 2007-05-21 21:10:17 UTC
Actually, I think it's libgdk-x11 receiving the display geometry changing and
accessing a null pointer or something - sig11 anyway. Once I found the right
debuginfo rpms, the stacktrace is pretty clear on that. Unfortunately, with
everything but bug-buddy having crashed, I don't see how I copy the trace out of
there...

So, this probably is a combination of xorg sending a geometry change event that
is not entirely correct (and sometimes crashing itself?), and gdk not validating
the structure entirely.

Comment 3 Osma Ahvenlampi 2007-05-21 21:16:21 UTC
Created attachment 155129 [details]
bug-buddy's stracktrace of a crashing app

got lucky after enough retries - only gnome-panel crashed so I had enough of a
session left to catch and save this :)

I got this by repeating "xrandr --output VGA --off" and "xrandr --output VGA
--auto" enough times (well, twice).

Comment 4 Ray Strode [halfline] 2007-05-22 00:05:42 UTC
ah, okay, moving to gtk2

Comment 5 Matthias Clasen 2007-05-22 02:14:39 UTC
Fixed in 2.10.12, which will go out as an update shortly after f7 gets released.

Comment 6 Osma Ahvenlampi 2007-05-22 07:31:52 UTC
Cheers. Any test build I could provide feedback on?

Comment 7 Matthias Clasen 2007-05-22 14:07:46 UTC
You can get it out of the build system:

http://koji.fedoraproject.org/koji/buildinfo?buildID=6818

Comment 8 Osma Ahvenlampi 2007-05-23 12:18:20 UTC
Thanks, I can verify that gtk2-2.10.12-1.fc7 fixed this problem for me.

Comment 9 Matěj Cepl 2007-05-23 14:07:47 UTC
Per reporters comment 8, closing as resolved in the CURRENTRELEASE
gtk2-2.10.12-1.fc7


Note You need to log in before you can comment on or make changes to this bug.