Bug 240779 - nash support for spaces in kernel command line
Summary: nash support for spaces in kernel command line
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd   
(Show other bugs)
Version: 5.0
Hardware: s390x
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Alexander Todorov
URL:
Whiteboard:
Keywords:
Depends On: 240777
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-21 16:37 UTC by Brad Hinson
Modified: 2008-05-21 15:26 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0437
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:26:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nash support for spaces in kernel command line (795 bytes, patch)
2007-05-21 16:37 UTC, Brad Hinson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0437 normal SHIPPED_LIVE mkinitrd bug fix and enhancement update 2008-05-20 13:11:44 UTC

Comment 1 Brad Hinson 2007-05-21 16:37:30 UTC
Created attachment 155110 [details]
nash support for spaces in kernel command line

Comment 2 RHEL Product and Program Management 2007-10-16 03:59:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Peter Jones 2008-01-31 23:17:46 UTC
Fixed in mkinitrd-5.1.19.6-21 .

Comment 6 Alexander Todorov 2008-04-02 16:34:05 UTC
Some information from bhinson on s390x:

on 5.1 we have FAIL with 
root=/dev/VolGroup00/LogVol00 selinux=0 vmhalt="CPU 0 CMD IPL CMS" BOOT_IMAGE=2
and 
root=/dev/VolGroup00/LogVol00 vmhalt="CPU 0 CMD IPL CMS" selinux=0 BOOT_IMAGE=2

e.g. no matter the parameters order.

on 5.2 snap#3 both cases PASS


on 5.1 testing with the values from comment #4 doesn't show the bug. We assume
that as "asdf" is not a valid argument some sanity check is in place before
parsing the values.

Comment 7 Alexander Todorov 2008-04-02 16:40:39 UTC
pjones,
can you answer the following questions please: 
1) As mentioned in comment #6 is there any validation/sanity check that only
supported parameters are passed on the command line?

2) Does the parameter order really not matter? 
bhinson explained:
the kernel will parse any and all args, and if there's a single number, it will
be interpreted as the runlevel, no matter where it is

Is this correct?

3) I tried testing with x86_64 but I may have been victim of 1). Also I've
noticed parameters like console="-- ttyS0,115200" when using Xen on i386, x86_64
and ia64. This is having quotes and space and is parsed as expected (unless it's
not parsed by --). Do you have any idea why? 

4) Based on 3) can you say for sure that it affects all arches as well? If yes
any hints for reproducing and testing on other arches are welcome.

Comment 9 Peter Jones 2008-04-03 14:50:12 UTC
1) no, none whatsoever, by intent.
2) the order matters only in that "init=/foo/bar" means to run /foo/bar as init,
and anything after an "init=" parameter is treated as command line arguments for
the init process *by the initrd* (not the kernel)
3) Not sure I understand the question here...
4) no arches do any special handling here AFAIK.

Comment 10 Alexander Todorov 2008-04-03 15:52:27 UTC
My grub.conf file is:

title Red Hat Enterprise Linux Server (2.6.18-53.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-53.el5 ro root=/dev/VolGroup00/LogVol00 
        initrd /initrd-2.6.18-53.el5.img

adding asdf="foo 0" to any or all of the 3 lines above doesn't cause the system
to poweroff (run level 0) but instead it boots into its previously configured
run level. 

This is on x86_64 with RHEL 5.1 Server GA. So I can't reproduce the desired
behavior. 

Given comment #6 and that this was originally filed against s390 I'd like to
move to VERIFIED and change the Hardware field to s390x. Is everybody happy with
that?

Thanks.

Comment 11 Brad Hinson 2008-04-03 17:59:56 UTC
That works for me.  Moving arch to s390x.

Comment 15 errata-xmlrpc 2008-05-21 15:26:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0437.html



Note You need to log in before you can comment on or make changes to this bug.