Bug 24079 - openssl in updates area built for wrong arch
openssl in updates area built for wrong arch
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: openssl (Show other bugs)
6.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-15 18:44 EST by Habig, Alec
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 17:32:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Habig, Alec 2001-01-15 18:44:48 EST
The openssl rpm (openssl-0.9.5a-2.6.x) in the sparc 6.X updates area is
built for "SPARC32PLUS, V8+ Required."  Thus, it won't run on older sparc
systems, which the rest of the distro is compiled for.  A comparison:

% file /usr/bin/openssl
/usr/bin/openssl: ELF 32-bit MSB executable, SPARC32PLUS, V8+ Required,
version 1, dynamically linked (uses shared libs), stripped

% file /bin/gzip
/bin/gzip: ELF 32-bit MSB executable, SPARC, version 1, dynamically linked
uses shared libs), stripped

Of course, I tried to rebuild the SRPM on my old sparc under RH 6.1, and it
"ar" dump core, so perhaps there's a good reason for this choice of
architecture - although the SuSe openssl-0.9.6 rpm works fine.
Comment 1 Need Real Name 2001-01-25 01:58:19 EST
This bug thoroughly breaks both old and new versions of up2date as well.
Comment 2 osi 2001-02-05 02:43:09 EST
Recompiling the SRPM on RH 6.2 (sun4c) works fine, so this looks like
an accidental mistake.  Ssh depends on openssl, so the upgrade breaks ssh.
Comment 3 Need Real Name 2001-02-10 16:17:56 EST
Oops, even pine refuses to work! What is the procedure? Will RedHat publish a
new rpm?
Comment 4 Need Real Name 2001-02-21 07:02:05 EST
I have done a rebuild on my Sparc of the src-rpm and now the package works fine
for me. For the lazey ones I have placed these new RPMs on:

http://home.sara.nl/~marco/rpm/sparc/

Good luck!

Marco
Comment 5 Need Real Name 2001-06-24 15:06:25 EDT
This issue has been listed as 'NEW' since January, and apparently no revised
package has been issued despite the clear problem of only needing RH to
re-compile for the proper machine and officially issue a new package.

A number of other Sparc bug issues remain hanging.

Has RH dropped support of Sparc altogether?
Comment 6 Nalin Dahyabhai 2001-07-03 14:49:55 EDT
There is a pending errata release for OpenSSL which fixes various security-
related issues, and the fix for this bug is bundled with it.

Note You need to log in before you can comment on or make changes to this bug.