Bug 240816 - glibc detects memory corruption
glibc detects memory corruption
Status: CLOSED DUPLICATE of bug 239344
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Coldwell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-21 17:43 EDT by Tim Niemueller
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-21 19:19:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log with full debugger run and glibc error message (5.71 KB, text/plain)
2007-05-21 17:43 EDT, Tim Niemueller
no flags Details

  None (edit)
Description Tim Niemueller 2007-05-21 17:43:34 EDT
Description of problem:
When starting Emacs this immediately fails with a glibc error message: memory
corruption detected.

Version-Release number of selected component (if applicable):
emacs-22.0.95-1.fc7
emacs-common-22.0.95-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install emacs
2. Start emacs
3. see glibc error message
  
Actual results:
glibc detects memory corruption.

Expected results:
Emacs should start.

Additional info:
I have installed emacs-debuginfo, here is the gdb stack trace:
(gdb) bt
#0  0x00000030628305b5 in raise () from /lib64/libc.so.6
#1  0x0000003062832060 in abort () from /lib64/libc.so.6
#2  0x0000003062868e1b in __libc_message () from /lib64/libc.so.6
#3  0x0000003062870d8c in _int_malloc () from /lib64/libc.so.6
#4  0x000000306287269d in malloc () from /lib64/libc.so.6
#5  0x000000000050ac5c in emacs_blocked_malloc (size=104, ptr=<value optimized
out>) at alloc.c:1244
#6  0x0000003062827ebd in _nl_intern_locale_data () from /lib64/libc.so.6
#7  0x000000306282874a in _nl_load_locale_from_archive () from /lib64/libc.so.6
#8  0x000000306282788d in _nl_find_locale () from /lib64/libc.so.6
#9  0x000000306282726e in setlocale () from /lib64/libc.so.6
#10 0x00000000004b285f in main (argc=1, argv=0x7fff8a7b2ee8) at emacs.c:1077
#11 0x000000306281daa4 in __libc_start_main () from /lib64/libc.so.6
#12 0x000000000040d9e9 in _start ()

My local is de_DE.UTF-8, also try with LANG=c, same result.
Comment 1 Tim Niemueller 2007-05-21 17:43:34 EDT
Created attachment 155131 [details]
Log with full debugger run and glibc error message
Comment 2 David Woodhouse 2007-05-21 19:19:54 EDT

*** This bug has been marked as a duplicate of 239344 ***

Note You need to log in before you can comment on or make changes to this bug.