Bug 240817 - OpenOffice.org won't start with nvidia binary driver multiple video cards
OpenOffice.org won't start with nvidia binary driver multiple video cards
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-21 19:23 EDT by regs
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 03:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of crashing startup (411.36 KB, text/plain)
2007-05-21 19:23 EDT, regs
no flags Details

  None (edit)
Description regs 2007-05-21 19:23:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):
   openoffice.org-core-2.0.4-5.5.22


How reproducible:
   Every time

Steps to Reproduce:
1. type ooffice
2. (command exits with return code of 0)
3.
  
Actual results:
    ooffice doesn't run

Expected results:
   ooffice to startup

Additional info:
   see attached strace file.  This problem appears to have started after
changing my X configuration to use multiple video cards.
Comment 1 regs 2007-05-21 19:23:07 EDT
Created attachment 155141 [details]
strace of crashing startup
Comment 2 regs 2007-05-21 19:40:14 EDT
Update: this appears to not be an openoffice bug, but a deeper bug with the
NVidia driver in this configuration.  This snippet from the strace file:

11052 read(7, "\0\t\3\1/\0\200\2\0\0005\0\230\303\235\10\0\0\0\0\t\0\0"..., 32) 
= 32
11052 exit_group(78)                    = ?
11042 <... waitpid resumed> [{WIFEXITED(s) && WEXITSTATUS(s) == 78}], 0) = 11052

And this error message from glxgears:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  78 (X_CreateColormap)
  Value in failed request:  0x0
  Serial number of failed request:  13
  Current serial number in output stream:  19

... seems a little too much of a coincidence (xscreensaver bombs out with a
similar error).
Comment 3 Caolan McNamara 2007-05-22 03:06:15 EDT
yes, it's a fairly common problem, but it is that of nvidia binary drivers
Comment 4 regs 2007-05-22 12:36:06 EDT
Yeah.  Turns out I was able to trace this back to the GLX drivers failing to
load.  A reinstall of the binary drivers fixed the problem.

It would be really nice, however, if OpenOffice would give you an error message
instead of just exiting with exit code 0 and no message.

Note You need to log in before you can comment on or make changes to this bug.