Bug 240822 - ksh not understanding named kill signals
Summary: ksh not understanding named kill signals
Status: CLOSED DUPLICATE of bug 200148
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: pdksh   
(Show other bugs)
Version: 3.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-22 02:33 UTC by Patrick Clohessy
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 09:33:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Clohessy 2007-05-22 02:33:50 UTC
Description of problem:

Latest version of ksh does not understand the named kill signal, TERM.

Latest version - pdksh-5.2.14-21.5
Output from kill -l
15   15 Terminated 

Previous version I was using - pdksh-5.2.14-21
Output from kill -l
15   TERM Terminated

Infact, most of the signals are no longer named in the latest ksh.

Version-Release number of selected component (if applicable):

pdksh-5.2.14-21.5

How reproducible:

Try to trap TERM signals then run a command with a non-zero exit status.

Steps to Reproduce:
1. Create a ksh script as follows

#!/bin/ksh

trap 'echo "TRAP"' TERM
ls -la /tmp/file_that_doesnt_exist
echo $?

  
Actual results:
ls: /tmp/file_that_doesnt_exist: No such file or directory
TRAP
1

Expected results:
ls: /tmp/file_that_doesnt_exist: No such file or directory
1

Additional info:

Comment 1 Tomas Smetana 2007-05-23 12:43:52 UTC
This looks to be a duplicate of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=200148.

Comment 2 Tomas Smetana 2007-06-06 09:33:21 UTC

*** This bug has been marked as a duplicate of 200148 ***


Note You need to log in before you can comment on or make changes to this bug.